vADC Forum

Reply
Occasional Contributor
Posts: 7
Registered: ‎02-25-2014
Accepted Solution

SteelApp HTTP Monitor and 302 vs 200 OK

Hello!

I'm trying to setup an http monitor to monitor our Cyberark servers.

The URL is https://<servername>.<domain>/PasswordVault/login.aspx

When I go to the URL in my browser, I get redirected to: /PasswordVault/logon.aspx?ReturnUrl=%2fPasswordVault%2fdefault.aspx

If I go to https://<servername>.<domain>/PasswordVault/default.aspx in my browser I get redirected to the same above URL

In my Monitor, I put the /PasswordVault/logon.aspx?ReturnUrl=%2fPasswordVault%2fdefault.aspx in the path, thinking I'd avoid any redirects and get an actual 200 OK return code. Not the case. According to STM, it's receiving a 302 no matter what URL I go to.

I've done a trace on my local machine with Fiddler and Chrome's built in dev tools and my PC is seeing HTTP 200 OK messages.

The reason this is an issue is because last night, the primary server went down, the APP wasn't loading the login page, but for somereasoon STM was still seeing a 302, i'm assuming that's from IIS on the server.

Anyone experienced anything similar with HTTP monitors and how did you get around it?

I'm running STM 9.6r1.

Contributor
Posts: 29
Registered: ‎10-19-2013

Re: SteelApp HTTP Monitor and 302 vs 200 OK

we did have a similiar problem, because the server is sending a different answer depending on user-agent value.

so testing with a real browser is different.

could you do a "curl" to that url and see whats coming back?

Occasional Contributor
Posts: 7
Registered: ‎02-25-2014

Re: SteelApp HTTP Monitor and 302 vs 200 OK

Hello, Thanks for the reply…

I did this and here’s what I got:

curl -k https://

.

/PasswordVault/logon.aspx?ReturnUrl=%2fPasswordVault%2fdefault.aspx

Object moved to here .


root@SR-HQ2:~# curl -k https://

.

/PasswordVault/auth/ldap

h1. Object Moved
This document may be found [here | https://

.

/PasswordVault/auth/ldap/]

Brocadian
Posts: 58
Registered: ‎11-29-2012

Re: SteelApp HTTP Monitor and 302 vs 200 OK

Does your application require specific a host header?

Have you tried setting the  host_header:    value in the monitor config?

Occasional Contributor
Posts: 7
Registered: ‎02-25-2014

Re: SteelApp HTTP Monitor and 302 vs 200 OK

Hi!

It doesn’t require a specific header as far as I know, but I did put the hostname (the same as on the SSL Cert) into the hostname field.

Highlighted
Brocadian
Posts: 58
Registered: ‎11-29-2012

Re: SteelApp HTTP Monitor and 302 vs 200 OK

Can you set the monitor  verbose:  to yes and post the output?

Occasional Contributor
Posts: 7
Registered: ‎02-25-2014

Re: SteelApp HTTP Monitor and 302 vs 200 OK

18/Sep/2014:21:44:45 -0400

INFO

Succeeded

18/Sep/2014:21:44:45 -0400

INFO

Response data&colon; HTTP/1.1 302 Found

18/Sep/2014:21:44:45 -0400

INFO

Cache-Control: no-cache, no-store, must-revalidate

18/Sep/2014:21:44:45 -0400

INFO

Pragma: no-cache

18/Sep/2014:21:44:45 -0400

INFO

Content-Type: text/html; charset=utf-8

18/Sep/2014:21:44:45 -0400

INFO

Expires: -1

18/Sep/2014:21:44:45 -0400

INFO

Location: /PasswordVault/auth/ldap

18/Sep/2014:21:44:45 -0400

INFO

Server: Microsoft-IIS/7.5

18/Sep/2014:21:44:45 -0400

INFO

X-Frame-Options: SAMEORIGIN

18/Sep/2014:21:44:45 -0400

INFO

Set-Cookie: CA22222=; path=/PasswordVault/; HttpOnly

18/Sep/2014:21:44:45 -0400

INFO

Set-Cookie: CA11111=; path=/PasswordVault/; HttpOnly

18/Sep/2014:21:44:45 -0400

INFO

Set-Cookie: CA33333=; path=/PasswordVault/; HttpOnly

18/Sep/2014:21:44:45 -0400

INFO

Set-Cookie: mobileState=Desktop; path=/PasswordVault/; HttpOnly

18/Sep/2014:21:44:45 -0400

INFO

Set-Cookie: ASP.NET_SessionId=a041mi45nipato555fxh2f45; path=/; HttpOnly

18/Sep/2014:21:44:45 -0400

INFO

X-UA-Compatible: IE=EmulateIE8

18/Sep/2014:21:44:45 -0400

INFO

Date: Fri, 19 Sep 2014 01:44:45 GMT

18/Sep/2014:21:44:45 -0400

INFO

Connection: close

18/Sep/2014:21:44:45 -0400

INFO

Content-Length: 147

18/Sep/2014:21:44:45 -0400

INFO

18/Sep/2014:21:44:45 -0400

INFO

18/Sep/2014:21:44:45 -0400

INFO

Object moved to here .

18/Sep/2014:21:44:45 -0400

INFO

</body></html>

18/Sep/2014:21:44:45 -0400

INFO

Writing request

18/Sep/2014:21:44:45 -0400

INFO

Writing request

18/Sep/2014:21:44:45 -0400

INFO

Connecting

Brocadian
Posts: 58
Registered: ‎11-29-2012

Re: SteelApp HTTP Monitor and 302 vs 200 OK

Looks like the connection is being redirected to "/PasswordVault/auth/ldap", Is the path in the monitor "/PasswordVault/auth/ldap"?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook