vADC Forum

Occasional Contributor
Posts: 7
Registered: ‎05-16-2016

Error when use getNodes with SOAP API



I try to get nodes in a Pool with SOAP API but I've got this error:


... (soapSmiley Frustratederver) Can't use string ("Web Pool") as an ARRAY ref while "strict refs" in use at /usr/local/zeus/zxtmadmin/lib/perl/Zeus/ZXTM/SOAP/ line 471. (Savon:Smiley FrustratedOAPFault)


i have tried with ruby and python language and I have the same result.


My code example:


#!/usr/bin/env ruby

require 'savon'


client = Savon.client do
  wsdl wsdl_pool
  namespace ''
  ssl_verify_mode :none

puts, message: {names: 'Web Pool'})



Anyone already have the same problem ?






Posts: 103
Registered: ‎04-22-2015

Re: Error when use getNodes with SOAP API

Hello - did you already raise this with support? Would also help to know which nodes are listed in the GUI associated with this web pool.


Also try with the REST API - REST is more commonly used these days than SOAP.



P, ...


Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.