vADC Docs

Brocade vTM Kernel Modules for Linux Software

by on ‎02-22-2013 07:25 AM - edited on ‎09-23-2015 07:23 AM by PaulWallace (5,893 Views)

The Brocade vTM Kernel Modules may be installed on a supported Linux system to enable advanced networking functionality – IP Transparency and Multi-Hosted Traffic IP Addresses.

 

Note: The  Kernel Modules are pre-installed in Brocade vTM Virtual Appliances, and in Cloud images where they are applicable. The Kernel Modules are not available for Solaris.

 

The modules

 

IP Transparency Module (ztrans)

 

The IP Transparency Module enables support for IP transparency in Brocade Virtual Traffic Manager software. When used, Brocade vTM will set the source IP address of packets it transmits to a server to match the source address of the remote client. Refer to the User Manual (Brocade vTM Product Documentation) for details of how to configure IP transparency. ztrans is supported for kernel versions up to and including version 3.2.

 

Multi-hosted IP Module (zcluster)

 

The Multi-hosted IP Module allows a set of clustered Traffic Managers to share the same IP address. The module manipulates ARP requests to deliver connections to a multicast group that the machines in the cluster subscribe to. Responsibility for processing data is distributed across the cluster so that all machines process an equal share of the load. Refer to the User Manual (Brocade vTM Product Documentation) for details of how to configure multi-hosted Traffic IP addresses. zcluster is supported for kernel versions up to and including version 3.19.

 

Installation

 

Prerequisites

 

Your build machine must have the kernel header files and appropriate build tools to build kernel modules.

 

You may build the modules on one machine and copy them to an identical machine if you wish to avoid installing build tools and kernel headers on your production traffic manager.

 

Installation

 

Unpack the kernel modules tarball, and cd into the directory created:

 

# tar –xzf brocade_vtm_modules_installer-2.9.tgz   

# cd brocade_vtm_modules_installer-2.9

 

Review the README within for late-breaking news and to confirm kernel version compatibility.

 

As root, run the installation script install_modules.pl to install all modules:

 

# ./install_modules.pl

 

To install only a specific set of modules, add the modules names as parameters. For example to install the only the IP Transparency module:

 

# ./install_modules.pl ztrans

 

If installation is successful, restart the vTM software:

 

# $ZEUSHOME/restart-zeus

 

If the installation fails, please refer to the error message given, and to the distribution specific guidelines you will find in the README file inside the stingray_modules_installer package.

 

Kernel Upgrades

 

If you upgrade your kernel, you will need to re-run the install-modules.pl script to re-install the modules after the kernel upgrade is completed.

 

Latest Packages

 

Packages for the kernel modules are now available via the normal Brocade vTM download service.

Comments
by olowokandi
on ‎06-03-2013 01:12 PM

im looking to use traffic ip ( Multi-hosted IP Module )but having trouble on my ubuntu server. when following these instructions i got this:

"You are running kernel version: 3.8.0-23-generic

The Stingray Traffic Manager kernel modules are supported on kernel

versions 2.6.11 to 3.2.0 inclusive.  Please install a supported kernel and

try again."

is there any alternatives to downgrading my kernel ?

by felixdpg
on ‎07-31-2013 12:20 AM

Hi:

Where I could found this module for solaris?.

Regards

Felix

Contributors