For more details, please see ourCookie Policy.

Virtual Router/ Firewall/ VPN

Occasional Contributor
Posts: 11
Registered: ‎03-29-2015
Accepted Solution

commit is not saving changes

After installing the vRouter via the vyatta-livecd_VSE6.7R5S1_amd64.iso, I tried to confogure the NICs; however, it seems that the commit command does not save my changes. 


I did the following: 



set interfaces ethernet eth0 address xx.xx.xx.xx/8  (IP has been removed)




The exit action tells me that the changes were not saved.  This is confirmed after rebooting as the interface is not configured. 

Occasional Contributor
Posts: 11
Registered: ‎03-29-2015

Re: commit is not saving changes

Solved.  The Vyatta_Ref_InstallUpgrade_VMware6.6R1.v01.pdf forgets to mention that in order to actually save the changes to the config.boot file, the "save" command needs to be entered after the commit, as "commit" only saves the changes to memory. 


bcvre-nutshell.pdf describes the commit and save processes. 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.