Sofware-Defined Networking

Occasional Contributor
Posts: 9
Registered: ‎10-12-2011

Vyatta vrouter 5600 & BVC : http 400 error

[ Edited ]



We installed a bvc and a vyatta vrouter 5600 to test NETCONF configuration. I installed pybvcsamples and tried to launch demo (I have already changed the vyatta controller IP address/login/password and the vrouter IP address/login/password.



"Netconf" service is configured on the 5600 and ssh is listening on port 22.


I can mount the node from the sample script, but I get http 400 errors when I tried to show the coinfiguration :


tddv-maqu-vyatta-02:/usr/local/script/pybvcsamples/1.3.0/samplenetconf/cmds# ./
>>> Adding 'vRouter' to the Controller ''
'vRouter' was successfully added to the Controller



tddv-maqu-vyatta-02:/usr/local/script/pybvcsamples/1.3.0/samplenetconf/cmds#  ./
<<< NETCONF nodes configured on the Controller
Nodes configured:
<<< NETCONF nodes connection status on the Controller
Nodes connection status:
   'controller-config' is connected
   'vRouter' is not connected




tddv-maqu-vyatta-02:/usr/local/script/pybvcsamples/1.3.0/samplenetconf/cmds#  ./
<<< 'Controller':, 'vRouter':
Failed, reason: http error 400 - 'bad request'
HTTP error 400 - 'Bad Request'
    "errors": {
        "error": [
                "error-type": "protocol",
                "error-tag": "unknown-element",
                "error-message": "Mount point does not exist."


thanks for your help,


Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.