Management Software

Reply
New Contributor
Posts: 3
Registered: ‎11-07-2017
Accepted Solution

"Error 16004: Member does not exist", appears with remove action but not with add action

[ Edited ]

I am trying to use the REST API call for BNA to add/remove member to a zone. When the action is add, it's working fine, but when the action is remove it say ""Error 16004: Member does not exist", appears with remove action but not with add action". I can't understand what's going on.

 

FYI: I am using the same object. Even when I do add twice, the zone will have same members twice. I can remove memebrs from the terminal perfectly fine, just when I try to remove from REST API it doesn't work.

Brocade Moderator
Posts: 414
Registered: ‎03-29-2011

Re: "Error 16004: Member does not exist", appears with remove action but not with add action

Hi,

 

which version of BNA are using?




If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution".


Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers. All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution"
New Contributor
Posts: 3
Registered: ‎11-07-2017

Re: "Error 16004: Member does not exist", appears with remove action but not with add action

14.2.1
New Contributor
Posts: 3
Registered: ‎11-07-2017

Re: "Error 16004: Member does not exist", appears with remove action but not with add action

After spending couple of hours, I figured out what the issue was.

 

The API is case sensitive, so when I add something it doesn't matter, because it will just add it .

 

But while removing it wasn't finding it because I was putting on lowercase.

 

The confusion came because of the way API and CLI works. If we do 'alishow' on command line, it shows on lowercase. I basically copied that and used that to add/remove. But from the API it has to be uppercase. 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook