Management Software

Reply
Occasional Contributor
Posts: 7
Registered: ‎07-17-2009

Adding Fabrics to BNA fails with errorCode=1.008

BNA version 11.3.0

Switch type: 62.3 (DCX) running Virtual Fabrics (FID 128,127,126)

Switch Fabric OS:  v6.4.1a2

I have ssh access from the Wintel BNA server to the SAN Switch using putty

When adding the switch I get "Invalid credentials for discovery" my user is logging in with Radius authentication and my credentials are:

Description: RADIUS Account

Enabled: Yes

Password Last Change Date: Unknown (UTC)

Password Expiration Date: Not Applicable (UTC)

Locked: No

Home LF Role: admin

Role-LF List: admin: 1-128

Chassis Role: admin

Home LF: 128

Note: This is an updated BNA from 11.1.0 to 11.3.0 - but I have same problem for 2 out of 22 switchs on another BNA server, which dosnt run Virtual Fabrics - they are backend routers.

Any suggestions about what to try ????

Regards

Chris

From the BNA server logfile I have snipped this:

2013-03-07 15:45:28,254 INFO  (Thread-42 (group:HornetQ-client-global-threads-1045939285)) Processing discovery request 10.200.56.124

2013-03-07 15:45:28,369 WARN  (fabricCollectionDiscoveryThreadPool (Thread-1)) Authentication failure on seed switch 10.200.56.124: error message = Authentication failed, errorCode=1.008

2013-03-07 15:45:28,371 ERROR (fabricCollectionDiscoveryThreadPool (Thread-1)) Exception while discovering fabric: 1008

2013-03-07 15:45:28,461 WARN  (fabricCollectionDiscoveryThreadPool (Thread-1)) This is a shared session, so this should not have happened sesion id='null', created='Thu Mar 07 15:45:28 CET 2013', last accessed='Thu Mar 07 15:45:28 CET 2013', stale='false',

2013-03-07 15:45:29,566 INFO  (WorkerThread#2) Entering getSystemInfo() with parameters: <none>

2013-03-07 15:45:29,576 INFO  (WorkerThread#2) Exiting getSystemInfo() after 9 msec. Return value: HashMap<String, String>(size=26)

2013-03-07 15:45:39,566 INFO  (WorkerThread#2) Entering getSystemInfo() with parameters: <none>

2013-03-07 15:45:39,574 INFO  (WorkerThread#2) Exiting getSystemInfo() after 8 msec. Return value: HashMap<String, String>(size=26)

2013-03-07 15:45:49,567 INFO  (WorkerThread#2) Entering getSystemInfo() with parameters: <none>

2013-03-07 15:45:49,575 INFO  (WorkerThread#2) Exiting getSystemInfo() after 8 msec. Return value: HashMap<String, String>(size=26)

2013-03-07 15:45:59,567 INFO  (WorkerThread#2) Entering getSystemInfo() with parameters: <none>

2013-03-07 15:45:59,574 INFO  (WorkerThread#2) Exiting getSystemInfo() after 7 msec. Return value: HashMap<String, String>(size=26)

2013-03-07 15:46:00,940 INFO  (Performance Monitor Polling Scheduler) Performance Monitor Collection Running ..

2013-03-07 15:46:09,572 INFO  (WorkerThread#2) Entering getSystemInfo() with parameters: <none>

2013-03-07 15:46:09,583 INFO  (WorkerThread#2) Exiting getSystemInfo() after 11 msec. Return value: HashMap<String, String>(size=26)

Frequent Contributor
Posts: 155
Registered: ‎09-07-2010

Re: Adding Fabrics to BNA fails with errorCode=1.008

Can you please share what user you are specifying for snmpv3 under the Discover > Add fabric discovery option .

Discover > Add fabric Discovery > SNMP > User Name ?

One thing to note is VF requires SNMPv3  .

Occasional Contributor
Posts: 7
Registered: ‎07-17-2009

Re: Adding Fabrics to BNA fails with errorCode=1.008

I have used both Automatically and a local user created on the san switch named snmpv3_user, which is copy on my account, ie. admin. I have added this user to the snmp v3 settings, with MD5 ad DES password. I can login with this user (so user/pass working) and I have used this on BNA 11.1.0 with success.

Creating a local user for this another of my "issues" - I would prefer a user in my external user repository (AD, Radius etc) but havent tested that to much, due to not overcomplicate the problem

Regards

Christian

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook