For more details, please see ourCookie Policy.

Mainframe & FICON

Occasional Contributor
Posts: 16
Registered: ‎02-25-2011

FICON Sequence not permitted

The following scenario: z10 with FICON Express4 cards connected to the 5100 switch (with 4Gbps LX SFP modules).

This is "new" installation, because z10 was relocated to another datacenter.

Several links to two 5100 switches. SOME of the links are not working, on mainframe side (Support Element panel) I see "Sequence not permitted" status. From switch side I see No_sync and orange LED.

This machne was working OK with another switch, "twin" of this one, no problems occured.

The only change (excpet street address change) was microcode level on z10 - ti was updated recently. Previous microcodes were approx. 1 year old.

In the Switch Event log I see the following:

Error. RLIR event. Switch Port ID is 18 (0x041200). Device Port Tag is 0x8023. Loss of signal or synchronization

Any clue?



Radoslaw Skorupka


External Moderator
Posts: 5,399
Registered: ‎02-23-2004

Re: FICON Sequence not permitted


since you are use LX SFP:

What is the approx. distance in the Fabric ?

Is the Port set as Long Distance ?

Have you tried to set the Port Speed Fixed ?

Is Brocade 5100 running with Ficon FOS Certified Release ?

Occasional Contributor
Posts: 16
Registered: ‎02-25-2011

Re: FICON Sequence not permitted

We are using LX as a standard in mainframe environment. The distance is approx. 20m (meters), the port is not set as long distance.

I tried auto-negotiate as well as fixed 4Gbps speed, no effect.

Since some ports work OK and only few does not work, I tried to compare those ports with others - maybe there is some difference in port settings. I found no differences except obvious things like s/n or port ID.

I also tried to found differences on host side - also no effect.

However I performed interesting tests:

Test 1. I unplugged the channel (host side) and plugged another one, defined as "not connected". Things changed - the port is synchronized as G-port. IMHO that's typical when you connect "non-switch-defined" CHPID to the switch.

Was: CHP.23---switch.18, changed to: CHP.D1---switch.18.

Test 2. I plugged "suspected" mainframe CHPID to another (free) port in the switch.

CHP.23---switch.05 (free port).

Effect - "Sequence not permitted" error. U-port, No_sync.

Note, that healthy channel plugged in wrong port yields F-port result.

Question: can it be issue with fillword? The switch is 8Gbps, SFP is 4Gbps, however maybe it's a problem "IDLE vs ARB(FF)" ?

Question2: I compared the ports settings using WebTools. Maybe I should use command line (SSH) and there are more detailed settings to compare?



Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.