Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎05-30-2013

supportftp - has Brocade kept this command (6.4.2a) up to date ?

After using DCFM/BNA for many years I am working at a site with no such tool and I need to use the cli commands to do things like configupload & supportsave.

I am using FOS 6.4.2a issue could be present on many other versions.

I'm not confident that Brocade has kept these commands up to date to work for example to work with a Windows server that is part of an AD domain using Ssh.

I also noticed that supportftp chokes on certain passwords, that contain characters such as '&' see below,

admin> supportftp -s -h server -u brocadeftp -p R0ck&roll%++

27232

rbash: roll%++: command not found

Also the help for this command does not mention the protocol but if everything else is correct (username, password, IP) it wants a protocol. I realize ftp is a protocol and its part of the command but the help is not been helpful.

supportftp Usage:

-S

-s

Lastly I'm not sure if the \ backslash character needs to be backslashed so that it can be interpreted properly be the ssh server running on the Windows server.

When I ssh on to a Windows server thats part of a domain (Active Directory) from say a Mac I need to specify something like ORG\\ggre001, username is ggre001, AD domain is ORG but the help for commands such as supportsave and configupload that use Scp are not clear about this.

The same confusion about the backslash applies to the directory part of the supportftp, backslash required before a backslash or not ?, for example home directory is C:\Users\ggre001 will this work without any additional backslash ?

Below is an example of the command with that was enterted with the normal backslash, the home dir is C:\Users\brocadeftp

rfp1sw01b48k:admin> supportftp

Host IP Addr:   xx.xx.xx.xx

User name:      brocadeftp

Remote Dir:     C:Usersbrocadeftp

Auto Upload protocol:   scp

Auto-FTP:       Off

Not sure if this is a true workaround, Brocade seems be hedging their bets, see below

admin> supportftp -s -h xx.xx.xx.xx -u brocadeftp -p R0ck--roll -d C:\\Users\\brocadeftp -l scp

supportftp: bad dir name

supportftp: parameters changed

admin>

admin> supportftp

Host IP Addr:   xx.xx.xx.xx

User name:      brocadeftp

Remote Dir:     C:\Users\brocadeftp

Auto Upload protocol:   scp

Auto-FTP:       Off

If anyone from Brocade could speak to the issues raised here, my feeling is that the features are a little dated and the documentation and help needs to be updated.

My feature suggestion, add file transfer ability to Web Tools !!, it will save your customers from requesting multiple firewall requests in environments that don't have  wide open Networks.

Community Manager
Posts: 100
Registered: ‎01-13-2009

Re: supportftp - has Brocade kept this command (6.4.2a) up to date ?

Hi oblivion,

I agree the docs are not specific about "\" usage when specifying the remote directory. I'll see about getting some further details for this.

With regards to your request for adding file transfer support to Web Tools, I checked to see what we have currently.  So, for FOS version you are currently running, FOSv6.4.2, Config uploads and downloads are supported. The steps below are from the FOS v7.1.0 WebTools manual but they appeared to be the same.

Config Upload:

http://www.brocade.com/downloads/documents/html_product_manuals/WT_AG_710/wwhelp/wwhimpl/js/html/wwhelp.htm#href=ConfigFW.06.2.html

Also, SupportSave was added to Webtools with FOS v7.1.0:

http://www.brocade.com/downloads/documents/html_product_manuals/WT_AG_710/wwhelp/wwhimpl/js/html/wwhelp.htm#href=Intro.03.11.html

Stay tuned for more on the first item!

New Contributor
Posts: 2
Registered: ‎05-30-2013

Re: supportftp - has Brocade kept this command (6.4.2a) up to date ?

The supportsave is not available at my version, the suggestion for configuplaod was helpful, however it still has issues with the backslash. I tried scp and ftp.,Ftp give me a -1 error code, scp give me configupload failed login/file info incorrect. I know the login information is correct so again it could be backslash.

I enabled the auto ftp in Webtools and its got the right info, would something like "tracedump -n" create it and then since auto ftp is enabled it would try to upload to the ftp server? or more precisely how could I force it to try and auto upload a trace?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook