Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 17
Registered: ‎08-18-2009

Trying to run Linux script to ssh to switch and do a configupload to backup configuration.

Any assistance would be appreciated.  I am running the script on Host1 to ssh to the switch and do a configupload command to scp the config backup to Host2.  I can sign onto the switch and run the configupload command to Host2 through CLI (non-interactive).  I can run other commands from Host1, ie. zoneshow, nodefind, etc...

But when I run the configupload, I get "Lost Connection".  Any clues?  Is the lost connection coming from the scp and Host2 connection?

Thanks.

Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: Trying to run Linux script to ssh to switch and do a configupload to backup configuration.

Have you tried save-simply-your-san available in windows bin of phyton source files

Frequent Contributor
Posts: 90
Registered: ‎12-26-2010

Re: Trying to run Linux script to ssh to switch and do a configupload to backup configuration.

is there a ssh timeout set on the switch?

Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: Trying to run Linux script to ssh to switch and do a configupload to backup configuration.

Yes their is, I believe its 5 minutes.

Contributor
Posts: 26
Registered: ‎08-12-2008

Re: Trying to run Linux script to ssh to switch and do a configupload to backup configuration.

Went through this with both a Windows and LINUX hosts and never did get it to work correctly.

If you have DCFM installed you can setup DCFM to backup the switch configs on a daily basis. This was how we got around it.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook