Fibre Channel (SAN)

Reply
Visitor
Posts: 1
Registered: ‎05-06-2014
Accepted Solution

Switch Explorer java exceptions

After updating my Java to the latest version, Version 8 Update 5. I cannot get SwitchExplorer Web Tools to access my Brocade 300 Switches. After logging in I get an error: Exception encountered during initialization: com.brocade.web.secsan.SecureSANException: white space not allowed I updated the firmware to 6.4.3f hoping it would help, but no luck.
Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: Switch Explorer java exceptions

Yep you are not the only one who has that issue after updating JAVA

 

Did any of the threads and their suggestions helped?

New Contributor
Posts: 2
Registered: ‎12-06-2013

Re: Switch Explorer java exceptions

I have same issue with ver 7 update 55. still looking for help.

Occasional Visitor
Posts: 1
Registered: ‎10-24-2014

Re: Switch Explorer java exceptions

Hi,

  I;ve had thuis with Windows 7 and JRE 8 64 bit on Firefox so I cannot administer our swicthes !  Did anybody work out why?

 

( On Chrom and IE it just redirected to the java.com/download page...)

 

Kind regards,

So

External Moderator
Posts: 4,985
Registered: ‎02-23-2004

Re: Switch Explorer java exceptions

So,

 

java 8 is not supported.

 

you must downgrade to java 7

TechHelp24
Brocadian
Posts: 1
Registered: ‎01-13-2012

Re: Switch Explorer java exceptions

FWIW - I have a system which *is* using Java 7 and I still get this error.

Occasional Visitor
Posts: 1
Registered: ‎06-28-2007

Re: Switch Explorer java exceptions

Is there no fix to this or do we need to just junk all our Brocade switches and buy another manufactures products?

 

suggesting going back to insecure versions of software is simply not an option for many people.

Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: Switch Explorer java exceptions

Greetings powerless.  Definitely valid points for sure.  I took a look at the latest docs and they also say "or latest version".  


powerless wrote:

Is there no fix to this or do we need to just junk all our Brocade switches and buy another manufactures products?

 

suggesting going back to insecure versions of software is simply not an option for many people.


So I've pinged a few people to find out whats up.  I'll write back with the response(s) I get.  Sorry for the inconvenience.  More to follow...

Regards,

Mike Eversole
Brocade Community Manager
Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: Switch Explorer java exceptions

I mentioned yesterday I'd look into this.  Here is the feedback from our Senior Product Manager:

 

"There have been a few inquiries on this topic. This is an issue with the current Java 8 update 25, which causes backward compatibility with Java 7 based programs. Oracle is going to fix this in Java 8 update 40 scheduled in March 2015. At the meantime, customers can use BNA to launch WebTools or use Java 7 as workarounds."

 

Now I know March is a bit of a stretch to wait for a fix by Oracle, but this is on them to fix.  Support for v8 is coming but isn't due for some time.

Regards,

Mike Eversole
Brocade Community Manager
Visitor
Posts: 1
Registered: ‎09-10-2010

Re: Switch Explorer java exceptions

I use Windows 7 with Java 7.71 now. (downgrade from Java 8.x)

 

Then i cange one Paramter in the security file (C:\Program Files (x86)\Java\jre7\lib\security\java.security).

 

I change     jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 256      to 256 from 2048.

 

 

I worked well with a lot of switches.

 

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook