Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎02-06-2013

Steps to migrate 4100s switches to 6510s

Hello all,

We are going under switches replacement due to EOSL. We are moving from 4100 to 6510.
The 4100 are running FOS 6.4.1b and moving to FOS 7.0.0 or 7.1.0 not sure yet.

One switch is the primary of the Fabric and the other, connected via dark fibre is the Secondary.

In the middle there are CWDM that interconnects the dark fibres between each switch. And on both ends, there are connected several 300s.

The switches run FOS Native and no VF are configured.

                                                   CDWM-CDWM
                            +-----------+      +----+    +----+       +-----------+
  +-----+                   |           |      |    |    |    |       |           |            +-----+
  | 300 |-------------------| 6510 Prim |------|    |    |    |-------| 6510 Sec  |------------| 300 |
  +-----+                   |           |      |    |    |    |       |           |            +-----+
                            |           |      |    |    |    |       |           |
  +-----+                   |           |      |    |    |    |       |           |
  | 300 |-------------------|           |------|    |    |    |-------|           |            +-----+
  +-----+                   |           |      |    |    |    |       |           |------------| 300 |
                            +-----------+      +----+    +----+       +-----------+            +-----+

I've been reading what are the steps to do the migration and came up with the following action plan:

1) configUpload from the 4100 Primary.
2) configDownload to the 6510 Primary.

What I am not sure here is if I need to run configUpload/configDownload with or without any parameters.

3) configUpload from 4100 Secondary
4) configDownload to the 6510 Secondary.

At this point, I will have the two 6510 switches with the same configuration that we have on our 4100s. The 6510 are still disconnected from the network. And the 4100 are in production.

So far, anything that I am missing? Anything that might cause a problem when moving the cables from the old switches to the new one? What about the DID?

5) Move the links that interconnect both switches, that is, the dark fibre that run from one Datacenter to the other.
6) Start moving the different links until we have all of them moved to the new switches.

At this point the new switches should be moving traffic from one place to another; the switches are in prod. The 4100s are ready to be shutdown.

Is step 5 and 6 in the correct order or should I move the fibre that interconnects both switches as the last step?

Anything that I might be missing in the whole action plan?

Thanks in advance for the help that you may provide.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook