Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 7
Registered: ‎01-08-2010

SAN16B (IBM_2005_16B) Admin password reset

Hello,

I am looking for help on reseting the admin password on IBM_2005_16B switch.

I have another switch SilkWorm3200, for which I know the password and I have the IP setup.

I connected the SAN16B to it and tried the PasswordReset utility through the SilkWorm. After executing it I get confirmation that passwords have been reset. However, I can not login through the serial port on the SAN16B.

On the SilkWorm I have fabric OS v3.0.2j.

Please, help!

Thank you!

Rad

External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: SAN16B (IBM_2005_16B) Admin password reset

this tools work only when both switch are in the same IP range, both switch must be ISL's connected, PID must be correct set otherwise the pw reset don't work.

TechHelp24
Occasional Contributor
Posts: 7
Registered: ‎01-08-2010

Re: SAN16B (IBM_2005_16B) Admin password reset

@TechHelp24:

I have both switches on the same LAN and fabric. However, I can't access SAN16B through web, so I don't know the PID setting.

Is there any alternative/manual way for reseting the admin password?

Thanks,

Rad

External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: SAN16B (IBM_2005_16B) Admin password reset

i note follow, you wrote:

IBM 2005 B16 = Genuine Brocade 3850

can you confirm the correct switch Type ?

TechHelp24
Occasional Contributor
Posts: 7
Registered: ‎01-08-2010

Re: SAN16B (IBM_2005_16B) Admin password reset

The exact model number on the switch is IBM 2005 16B.

It bears the IBM logo.

Thanks,

Rad

External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: SAN16B (IBM_2005_16B) Admin password reset

This is the Brocade 3850 ant the Paswordreset utility don't work with this switch.

you need to follow this procedure in order to reset the Password

http://community.brocade.com/home/docs/DOC-1644

TechHelp24
Occasional Contributor
Posts: 7
Registered: ‎01-08-2010

Re: SAN16B (IBM_2005_16B) Admin password reset

OK, I believe I followed the notes:

1.) I don't know the root login.

2.) I executed Password Recovery Using the Boot PROM, as follows:

     The system is coming up, please wait...

     Read board ID of 0x80 from addr 0x23

     Read extended model ID of 0x19 from addr 0x22

     Matched board/model ID to platform index 6


     Read board ID of 0x80 from addr 0x23

     Read extended model ID of 0x19 from addr 0x22

     Matched board/model ID to platform index 6

     Checking system RAM - press any key to stop test


     Checking memory address: 00100000


     System RAM test using Default POST RAM Test succeeded.


     Press escape within 4 seconds to enter boot interface.


     1) Start system.

     2) Recover password.

     3) Enter command shell.


     Option? 3

     Password:

     > printenv

     AutoLoad=yes

     ENET_MAC=00051E07059A

     InitTest=MEM()

     LoadIdentifiers=Fabric Operating System;Fabric Operating System

     OSLoadOptions=quiet

     OSLoader=ATA()0x20128;ATA()0x50b00

     OSRootPartition=hda1;hda2

     SkipWatchdog=yes

     >

     > boot MEM()0x20128 -s

     Booting "Manually selected OS" image.

     MEM()0x20128 has an invalid magic number (0x00000000)

     OSLoader contains no bootable devices.

3.) It didn't work. I am not sure whether I made a mistake or the problem is with the OS level. On normal boot I read the following:

     The system is coming up, please wait...

     Read board ID of 0x80 from addr 0x23

     Read extended model ID of 0x19 from addr 0x22

     Matched board/model ID to platform index 6


     Read board ID of 0x80 from addr 0x23

     Read extended model ID of 0x19 from addr 0x22

     Matched board/model ID to platform index 6

     Checking system RAM - press any key to stop test


     Checking memory address: 00100000


     System RAM test using Default POST RAM Test succeeded.


     Press escape within 4 seconds to enter boot interface.

     Booting "Fabric Operating System" image.

     Entry point at 0x01000000 ...


     loading kernel


     loaded at:     01000000 013F7364

     board data at: 013F5324 013F5364

     relocated to:  01005110 01005150

     zimage at:     0100597D 01169E3A

     initrd at:     0116A000 013F4C00

     avail ram:     013F8000 08000000


     Linux/PPC load:

     BootROM command line: quiet

     Uncompressing Linux...done.

     Now booting the kernel

     PCI: Cannot allocate resource region 0 of device 0000:00:00.0

     Installing Linux 2.6 Kernel

     Attempting to find a root file system on hda1...

     INIT: version 2.78 booting

     INIT: Entering runlevel: 3

     uptime: 4293889119; sysc_qid: 0

     2010/01/11-19:20:36, , 1256,, INFO, IBM_2005_16B, Processor rebooted - Unknown

    

     SNMP Research EMANATE/Lite Agent Version 16.2.0.9

     Copyright 1989-2006 SNMP Research, Inc.


     Fabric OS (IBM_2005_16B)


     IBM_2005_16B console login: sysctrld: all services Standby

     2010/01/11-19:20:45, , 1257,, INFO, IBM_2005_16B, The effective configuration has changed to entire.

     TS_MSG_UPDATE_TZONE message

     sec0: Security is initializing........

     sysctrld: all services Active

     POST1: Started running Mon Jan 11 19:20:48 GMT 2010

     POST1: Test #1 - Running turboramtest

     POST1: Test #2 - Running portregtest

     POST1: Script PASSED with exit status of 0 Mon Jan 11 19:20:50 GMT 2010 took (0:0:2)

     POST2: Started running Mon Jan 11 19:20:52 GMT 2010

     POST2: Test #1 - Running portloopbacktest (TXRX INTERNAL)

     POST2: Test #2 - Running minicycle (TXRX INTERNAL)

     POST2: Running diagshow

     POST2: Script PASSED with exit status of 0 Mon Jan 11 19:21:11 GMT 2010 took (0:0:19)

     2010/01/11-19:21:12, , 1258,, INFO, IBM_2005_16B, Initializing ports...

     2010/01/11-19:21:12, , 1259,, INFO, IBM_2005_16B, Port initialization completed.



External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: SAN16B (IBM_2005_16B) Admin password reset

--->>> 2.) I executed Password Recovery Using the Boot PROM, as follows:

you need to Reset the FOS Password and not the BootProm password, so precede please as descripted in the guide with password recovery.

the printenv show OSLoader=ATA()0x20128;ATA()0x50b00

this is the boot MEM.

However i note in the output diverse Error like HAM-1004 ( for details see the Error message manuals ) , probable the switch have hardware problem.

TechHelp24
Occasional Contributor
Posts: 7
Registered: ‎01-08-2010

Re: SAN16B (IBM_2005_16B) Admin password reset

TechHelp24,

Thank you!

I managed to reset the passwords. The document, however, is mixed up. Here is the correct sequence of actions for future reference:

Enter command shell.

> printenv

AutoLoad=yes

ENET_MAC=0060696019B4

InitTest=MEM()

LoadIdentifiers=Fabric Operating System;Fabric Operating System

OSBooted=MEM()0xF0000000

OSLoadOptions=quiet;quiet

OSLoader=MEM()0xF0000000;MEM()0xF0800000

OSRootPartition=hda1;hda2

SkipWatchdog=yes

> boot ATA()0xF0000000 -s

> mount -o remount,rw,noatime /

> mount /dev/hda2 /mnt

> /sbin/passwddefault

> reboot -f



Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook