Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 8
Registered: ‎09-16-2011

SAN Name Server Issue

Hi,

The Configuration

I have configured a fabric using 1xQlogic 5600 with 2xBrocade M5424 connected via ISL.

The Qlogic has Firmware version 7.4.0.22.0 running in Interop Mode 0 - FC-SW2 (Standard) and is the Principle Switch.

The Brocades have Firmware version 6.4.2 running in Interop Mode 3 - McDATA Open Fabric Mode.

There is NO Zoning Configuration and the Default is Set to Allow All.

There are 2xHBAs connected to each Brocade switches and 2xStorage Arrays connected to the Qlogic Switch.

All Domain IDs and Port Type are configured and the ISLs between the switches are up and all seems well.

Now for the PROBLEM.

When I query the Name Server on the Qlogic I see all the Devices on the SAN.

If I query the Name Server on any of the Brocades using nsallshow and nscamshow I see the 4xHBAs connected to the Brocade Switches

and only the Device with the Lowest Port Index connected to the Qlogic switch.

If I change the ports to which the storage is connected or connect a HBA to the Qlogic switch the behaviour stays the same

only the Device with the Lowest Port Index connected to the Qlogic switch is returned.

Has anybody come accross this before?

Anybody got any advice other than using Access Gateway Mode?

Any Ideas?

Super Contributor
Posts: 635
Registered: ‎04-12-2010

Re: SAN Name Server Issue

What is your reason not to use the AG mode?

I would assum that the AG mode is the less painful way to intgrate the M5424. I can not see any disadvatages. But to be honest I have never worked with QLogic switches.

Andreas

Occasional Contributor
Posts: 8
Registered: ‎09-16-2011

Re: SAN Name Server Issue

Not to be rude or anything just to keep this on track - I am aware of AG mode and how to implement it and that many consider it the best way to go ect.

This issue is NOT about AG mode or it's advantages on disadvantages.

It IS about the Nameserver issue and trying to solve it if possible.

David

Super Contributor
Posts: 635
Registered: ‎04-12-2010

Re: SAN Name Server Issue

You know that interopt mode is everytime a compromise and a loss functionality.

If you are intrested in avoiding any conflicts or production issue you should think about AG.

It looks that you have currently a not supported configuration inplace.

Andreas

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook