Fibre Channel (SAN)

Reply
Super Contributor
Posts: 260
Registered: ‎04-09-2008

Radius auth error after FOS upgrade

Hi Gurus,

My friends having some trouble after a recent FOS upgrade. I tried reviewing the release notes but there are too many to scan thru.

Would like to know if anyone has exp the same problem and knows a possible solution. Will save a lot of time, thanks in advance

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I changed the Radius server configuration for a Brocade Switch with 6.0.1 FOS version. Earlier the configuration was running with CHAP protocol and since the requirement of upgrade in authentication I had to change it to PEAP-MSVCHAP2 (in short CHAP2 protocol). Though the change happened successfully but now for any and every login by any authenticated user on that Brocade Fabric is getting following message after login.

rlm_eap: EAP-Message not found


though the login is successful and I dont see any issue with the fabric too but I need to get rid of the above message as when any other users login they would too receive the same and make the fuss of it(You know how it is!!!!!).

Could please check the same and let me know for any possible solution?

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Biju


External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: Radius auth error after FOS upgrade

Biju,

what kind of Server use your frind as RADIUS ? Win, Linux..... ?

and which Client Type ?

TechHelp24
Super Contributor
Posts: 260
Registered: ‎04-09-2008

Re: Radius auth error after FOS upgrade

Thanks for responding Techhelp.

From the updates my friend has given, it seems to me that the firmwaredownload has caused the flash to be corrupt. Initially I thgt the error message appeared on all switches, but he's mentioned that only one switch is affected. Also on this switch I asked him to run errdump but does not yield any result.

I have asked him to respond to the queries you have posted.

Will also let everyone if its already been resolved, apologies for the delay in reply, was on vacation for a few days.

Regards,

Biju

Super Contributor
Posts: 260
Registered: ‎04-09-2008

Re: Radius auth error after FOS upgrade

The details are as follows

The the RADIUS server is CISCO ACS server (WINDOWS) and the client type is BROCADE

And the error appears only in the production fabric and the same FOS with the same radius works fine for him. The FOS does not seem to be corrupt from the latest response I have got.

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: Radius auth error after FOS upgrade

Biju,

i have test here some FOS upgrade in some circumstance , and i am the opinion, this error is due security reason beetwen the radius DB and the local switch aaa.

i am not 100% sure but 95 %

I must make another test, and coming back with a feedback middle next week.

BTW> is the switch from your friend running now ?

TechHelp24

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.