Fibre Channel (SAN)

Reply
Contributor
Posts: 26
Registered: ‎01-20-2011

FTB Type 2 Miss

Can someone explain these counters?

er_type1_miss            0           frames with FTB type 1 miss
er_type2_miss            2532        frames with FTB type 2 miss  - ! May need attention -
er_type6_miss            0           frames with FTB type 6 miss

Specifically the type2 miss, we often seem to see these when we're running out of buffer credits but nobody can seem to explain what these counters actually mean.
Frequent Contributor
Posts: 104
Registered: ‎07-27-2009

Re: FTB Type 2 Miss

Most likely this is on a port located on an FC8-48 card. The type2_miss increments whne there are failed or invalid ALPA lookups on shared area ID's on these cards. Very often due to a lingering defect or incorrect registration.

If you bounce the two ports which share the area-id and clear the stats you most likely will have fixed the problem.

Port witht he same area-id look like:

  160    7   32   28d7c0   --     N8   No_Module   FC 
161    7   33   28d780   --     N8   No_Module   FC 
162    7   34   28d740   --     N8   No_Module   FC 
163    7   35   28d700   --     N8   No_Module   FC

As you can see the area ID is d7 and the ALPA normally is 00. On shared area ports two bits are used from the ALPA address which translate to c0,80,40


Again, to fix this you most likely need to disable all ports and then re-enable them again.

Cheers

E

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: FTB Type 2 Miss

Thanks Erwin for the update, because there is not much info explaining these kind of errors (it's funny the description you get in the manual for this counter...)

grlivin,

In which port are you getting these errors? only in one?

Does the switch uses FCR?

do you see these counter increasion continuously or from time to time?

do you experience any kind of impact?

rgds

Highlighted
Contributor
Posts: 26
Registered: ‎01-20-2011

Re: FTB Type 2 Miss

Erwin,

Thanks for the info!  It's nearly impossible to find information about some of these more esoteric counters.    From first glance it sounds like this may just be normal for this config.  This is on an edge BladeCenter switch that is in Access Gateway mode...so more than one blade/system is using the same uplink port...could that explain why these are ticking up?

Contributor
Posts: 26
Registered: ‎01-20-2011

Re: FTB Type 2 Miss

Felipon,

We see these on all the external uplinks on these Edge switches with smilar numbers.   As for FCR, I don't think we're using it at the edge level, but the core DCX and Directory likely are?   This is not my setup, this is a customer I support.  As far as I know there is no current apparent impact reported by the customer.  They only thing I see that may be causing some issues is they are getting some high conjestion on one of the uplinks to the point it's discarding some frames, however they are pummeling the SAN so I do not find this surprising.

Thanks,

GRL

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook