Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 8
Registered: ‎10-14-2014
Accepted Solution

FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

Hi All,

 

We have a ESXi 5.5 with a CNA card QLE 8242 connected to Brocade 8000 switch, we have configured the switch with the below configuration. The FCoE devices - wwpn is not logging into the switch, the card is detected and showing in ESXi 5.5

 

Can anyone please help ?

 

The CEE, vlan classifiers, fcoe default vlan is configured as below in the switch. Please let us know what could be the issue. FOS running is v6.4.2

 

switch#show running-config
!
hostname switch
!
no protocol spanning-tree
!
vlan classifier rule 1 proto fcoe encap ethv2
vlan classifier rule 2 proto fip encap ethv2
vlan classifier group 1 add rule 1
vlan classifier group 1 add rule 2
!
cee-map default
priority-group-table 1 weight 40 pfc
priority-group-table 2 weight 60
priority-table 2 2 2 1 2 2 2 2
!
cee-map css1
priority-group-table 1 weight 50 pfc
priority-group-table 2 weight 50
!
interface Vlan 1
!
interface Vlan 3
fcf forward
!
interface Vlan 35
!
interface TenGigabitEthernet 0/0
switchport
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
!
interface TenGigabitEthernet 0/1
switchport
switchport mode access
switchport access vlan 35
no shutdown
cee default
!
interface TenGigabitEthernet 0/2
switchport
switchport mode access
switchport access vlan 35
no shutdown
cee default
!
interface TenGigabitEthernet 0/3
shutdown
!
interface TenGigabitEthernet 0/4
shutdown
!
interface TenGigabitEthernet 0/5
shutdown
!
interface TenGigabitEthernet 0/6
shutdown
!
interface TenGigabitEthernet 0/7
shutdown
!
interface TenGigabitEthernet 0/8
shutdown
!
interface TenGigabitEthernet 0/9
shutdown
!
interface TenGigabitEthernet 0/10
shutdown
!
interface TenGigabitEthernet 0/11
shutdown
!
interface TenGigabitEthernet 0/12
shutdown
!
interface TenGigabitEthernet 0/13
shutdown
!
interface TenGigabitEthernet 0/14
shutdown
!
interface TenGigabitEthernet 0/15
shutdown
!
interface TenGigabitEthernet 0/16
shutdown
!
interface TenGigabitEthernet 0/17
shutdown
!
interface TenGigabitEthernet 0/18
shutdown
!
interface TenGigabitEthernet 0/19
shutdown
!
interface TenGigabitEthernet 0/20
shutdown
!
interface TenGigabitEthernet 0/21
shutdown
!
interface TenGigabitEthernet 0/22
shutdown
!
interface TenGigabitEthernet 0/23
shutdown
!
protocol lldp
advertise dcbx-fcoe-app-tlv
advertise dcbx-fcoe-logical-link-tlv
!
line console 0
login
line vty 0 31
login
!
end

 

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

deep,

 

I think this is a compatibility issue, beetwen the FOS / CNA Bios and FW, and VMware Drivers.

 

you should upgrade the FOS on Brocade 8000 - latest supported release is 7.1.2b - FOS 6.4.2 is to old and not tested with

VMware 5.5

 

 

TechHelp24
Occasional Contributor
Posts: 8
Registered: ‎10-14-2014

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

Thanks Antonio, we upgraded to the latest code we have i.e. v7.1.1c

 

The FC wwpns of the Qlogic 8242 CNA card is 21:00:00:0e:1e:0f:69:b3 and 21:00:00:0e:1e:0f:69:b7

 

Now when I do

 

fcoe --loginshow <port no>

 

MP_8000B:admin> fcoe --loginshow 9
Number of connected devices: 0

 

But now in GUI I am getting error messages as below

 

ERR - The FCoE device with following WWN is not a member of the login group:21:00:00:0e:1e:0f:69:b3

 

Hence I created an fcoelogingroup and added the above FCoE wwpns but still it doesnt seem to login .....

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

Hi deep,

 

this is not claer to me.

 

you say,  loginshow at port "9" have not device listed, on other hand;

 

--->>>But now in GUI I am getting error messages as below

 

ERR - The FCoE device with following WWN is not a member of the login group:21:00:00:0e:1e:0f:69:b3

 

you get from the GUI the information from CNA WWN ????

 

what say this to us:

 

if this is the correct WWN, then the switch port see some for some reason info from CNA, in this case the correct WWN.

 

question:

 

are you sure port 9 is the correct Port ?

 

try follow:

 

replace SFP to affected port with another SFP, if you working whit TWINAX Cable, test another cable is probable the cable is defective.

 

 

 

 

 

TechHelp24
Occasional Contributor
Posts: 8
Registered: ‎10-14-2014

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

Yes it is port 9 i.e. TE 0/1 and port 10 i.e. TE 0/2, both the ports are Online and there is green light

 

 # show ip interface brief

TenGigabitEthernet 0/1 unassigned up up
TenGigabitEthernet 0/2 unassigned up up

 

 > switchshow

 

8 8 010800 -- 10G Online FCoE VF-Port 0 VN-Port(s)
9 9 010900 -- 10G Online FCoE VF-Port 0 VN-Port(s)

 

But no devices fcoe devices are logged in at 9 and 10, I am sure that the CNA ports are connected to TE 0/1 and TE 0/2 i.e. port 9 and port 10, 

The SFP used is a Brocade SFP 10Gb SR

 

But in the switch GUI there is continous error message as below

ERR - The FCoE device with following WWN is not a member of the login group:21:00:00:0e:1e:0f:69:b3

 

Occasional Contributor
Posts: 8
Registered: ‎10-14-2014

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

The physical transfer medium used is a FC cable

Occasional Contributor
Posts: 8
Registered: ‎10-14-2014

Re: FCoE devices unable to login - Environment - ESXi5.5 Qlogic CNA 8242 connected to Brocade FCoE

Thanks Antonio, created a fcoelogingroup by using the option allowall, then fcoedevices logged in.

 

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.