Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 11
Registered: ‎05-26-2013

Error messages FW-1436 and FW-1424 in my Brocade logs

Hi All,

I have got an alert from my IBM DS storage stating Logical Drive is not through the preferred path later was able to see error messages in my Brocade switch event logs with message ID's FW-1436 and FW-1424. Please help me to confirm what went wrong??

Thanks,

Nayab

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

Hi,

Below is the definition of those events:

FW-1424

Message:

<timestamp>, , <sequence-number>,, WARNING, <system-name>, Switch status changed from <Previous state> to <Current state>.

Probable Cause:

Indicates that the switch status is not in a healthy state. This occurred because of a policy violation.

Recommended Action:

Run the switchStatusShow command to determine the policy violation.

Severity WARNING

FW-1436

Message:

<timestamp>, , <sequence-number>,, WARNING, <system-name>, Switch status change contributing factor Marginal ports: <Num of marginal ports and the port numbers> marginal ports. (Ports <Unknown>)

Probable Cause:

Indicates that the switch status is not in a healthy state. This occurred because the number of marginal ports is greater than or equal to the policy set using the switchStatusPolicySet command.

A port is faulty when the port value for Link Loss, Synchronization Loss, Signal Loss, Invalid word, Protocol error, cyclic redundancy check (CRC) error, Port state change or Buffer Limited Port is above the high boundary.

Recommended Action:

Replace any faulty or deteriorating small form-factor pluggables (SFPs).

Severity WARNING

so I recommend you to review the status of the port that reported the event, since it may be faulted.

Kind regards,

Felipon

Occasional Contributor
Posts: 11
Registered: ‎05-26-2013

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

Hi Felipon,

I am able to see status healthy. Please find the output below.

bsw7:root> switchstatusshow

Switch Health Report                        Report time: 05/27/2013 03:18:08 PM

Switch Name:    bsw7

IP address:     172.29.44.94

SwitchState:    HEALTHY

Duration:       1297:36

Power supplies monitor  HEALTHY

Temperatures monitor    HEALTHY

Fans monitor            HEALTHY

Flash monitor           HEALTHY

Marginal ports monitor  HEALTHY

Faulty ports monitor    HEALTHY

Missing SFPs monitor    HEALTHY

bsw6:root> switchstatusshow

Switch Health Report                        Report time: 05/27/2013 03:20:30 PM

Switch Name:    bsw6

IP address:     172.29.44.93

SwitchState:    HEALTHY

Duration:       1132:16

Power supplies monitor  HEALTHY

Temperatures monitor    HEALTHY

Fans monitor            HEALTHY

Flash monitor           HEALTHY

Marginal ports monitor  HEALTHY

Faulty ports monitor    HEALTHY

Missing SFPs monitor    HEALTHY

Thanks,

Nayab

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

Which port reported the error? Please perform a portshow on it, to see its current status.

Occasional Contributor
Posts: 11
Registered: ‎05-26-2013

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

For the ports 13 and 12 please check the Logs Image as well.IMAG1400.jpg

zsswbsw7:root> portshow 13

portName: ZSSWMASB2_S4P0

portHealth: HEALTHY

Authentication: None

portDisableReason: None

portCFlags: 0x1

portFlags: 0x24b03       PRESENT ACTIVE F_PORT G_PORT U_PORT LOGICAL_ONLINE LOGIN NOELP LED ACCEPT

portType:  10.0

POD Port: Port is licensed

portState: 1    Online

portPhys:  6    In_Sync

portScn:   32   F_Port

port generation number:    473656

portId:    020d00

portIfId:    4302000b

portWwn:   20:0d:00:05:1e:05:25:88

portWwn of device(s) connected:

        10:00:00:00:c9:5f:d4:f3

Distance:  normal

portSpeed: N4Gbps

LE domain: 0

Interrupts:        814648     Link_failure: 966965     Frjt:         0

Unknown:           0          Loss_of_sync: 87967      Fbsy:         0

Lli:               814582     Loss_of_sig:  175908

Proc_rqrd:         319        Protocol_err: 0

Timed_out:         0          Invalid_word: 123

Rx_flushed:        0          Invalid_crc:  14

Tx_unavail:        0          Delim_err:    0

Free_buffer:       0          Address_err:  0

Overrun:           0          Lr_in:        13

Suspended:         0          Lr_out:       1

Parity_err:        0          Ols_in:       1

2_parity_err:      0          Ols_out:      439538

CMI_bus_err:       0

Port part of other ADs: No

zsswbsw7:root> portshow 12

portName: ZSSWMASB2_S3P1

portHealth: HEALTHY

Authentication: None

portDisableReason: None

portCFlags: 0x1

portFlags: 0x24b03       PRESENT ACTIVE F_PORT G_PORT U_PORT LOGICAL_ONLINE LOGIN NOELP LED ACCEPT

portType:  10.0

POD Port: Port is licensed

portState: 1    Online

portPhys:  6    In_Sync

portScn:   32   F_Port

port generation number:    473654

portId:    020c00

portIfId:    43020008

portWwn:   20:0c:00:05:1e:05:25:88

portWwn of device(s) connected:

        10:00:00:00:c9:5f:fa:99

Distance:  normal

portSpeed: N4Gbps

LE domain: 0

Interrupts:        814052     Link_failure: 966996     Frjt:         0

Unknown:           0          Loss_of_sync: 87976      Fbsy:         0

Lli:               813940     Loss_of_sig:  175918

Proc_rqrd:         756        Protocol_err: 0

Timed_out:         0          Invalid_word: 50

Rx_flushed:        0          Invalid_crc:  8

Tx_unavail:        0          Delim_err:    0

Free_buffer:       0          Address_err:  0

Overrun:           0          Lr_in:        20

Suspended:         0          Lr_out:       0

Parity_err:        0          Ols_in:       0

2_parity_err:      0          Ols_out:      439556

CMI_bus_err:       0

Port part of other ADs: No



Thanks,

Nayab

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

Those ports have many errors but the y could be old. I recommend you to clear the stats (with commands: statsclear y slotstatsclear) and monitor if those events reappear. If so, check the output of portshow <port> and portstatsshow <port> in order to see if any kind of error is logged. If physical errors are logged (such as CRC) you should review/replace the Hardware elements involved (cable, hba, sfp, patch-panel).

Rgds

Occasional Contributor
Posts: 11
Registered: ‎05-26-2013

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

Hi Felipon,

I have checked the portstatsshow  <Port>  for all the ports in both the switches i was not able to see any errors. So does this mean nothing serious as i was able to see a AMBER light flashing on one of the port. Anyways now i have run above command for all the ports i will go and check once again and let you know if its still AMBER i will open a case with Brocade.

Thanks,

Nayab

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

If there are not errors anymore, it may have been an isolated issue; just keep the monitored in case errors appear.

On the other hand, when it comes to the port with the flashing light, it may be because it has the beacon on. Please, try the command

portbeacon --show <port> to see if the beacon is Active. If so, turn it off with portbeacon --disable <port>

Occasional Contributor
Posts: 11
Registered: ‎05-26-2013

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

But i din find the portbeacon command in my console ???

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Error messages FW-1436 and FW-1424 in my Brocade logs

What's the FOS and switch model?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook