Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎03-06-2013

Brocade HBA on Sparc

Hi

  According to both Brocade and Oracle, Brocade 415 HBA is certified & supported by Solaris 10 on SPARC and x86 platforms.

  After installing Brocade 415 into Oracle T4, installing latest Brocade driver and rebooting, HBA does not show up in Solaris (fcinfo hba-port). "dmesg" shows the following warning from Brocade "bfa" driver:

Feb 26 20:33:17 csgams19 bfa: Brocade FCA Driver v3-2-0-0

Feb 26 20:33:17 csgams19 pcieb: PCIE-device: pci@8, pcieb13

Feb 26 20:33:17 csgams19 genunix: pcieb13 is /pci@400/pci@2/pci@0/pci@8

Feb 26 20:33:17 csgams19 pcieb: PCIE-device: pci@8, pcieb13

Feb 26 20:33:17 csgams19 bfa: WARNING: bfad0-bfad_registers_setup: ddi_regs_map_setup failed

  Anyone seen this before?

  Thank you!

-Alex

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: Brocade HBA on Sparc

I've Brocade 425 ( DUAL PORT ) installed in a very OLD Sun SPARC T2000 Sparc, and work fine.

have you tried another PCI Slot ?

what is the SUN Server Model and FW/BIOS vesion ?

TechHelp24
New Contributor
Posts: 2
Registered: ‎03-06-2013

Re: Brocade HBA on Sparc

Correct answer: HBA had old boot code. After upgrading HBA boot code, HBA work in Solaris just fine.

The trick was to move HBA card to x86 system, use Brocade LiveCD to upgrade boot code, then move card back to T4.

Thanks

-Alex

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.