Fibre Channel (SAN)

Reply
New Contributor
Posts: 3
Registered: ‎02-10-2011

Brocade 5300 upgrade fail

Hi Guys,

I opened this thread because I would like to get some advices about upgrading 5300 switches. Last year I upgraded few machines to v6.3.2b , but some of them crashed

Now I have to upgrade again, but now I will use FOS v6.3.2d.

Can anyone help me what should I do to avoid this?

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: Brocade 5300 upgrade fail

--->>>Can anyone help me what should I do to avoid this?

Sure. I'll provide to assist you with "firmwaredownload"

Post please output from "firmwareshow" command.

make sure you FTP Server is in same IP range as the Brocade switch.


TechHelp24
Regular Contributor
Posts: 226
Registered: ‎01-08-2011

Re: Brocade 5300 upgrade fail

Hello,

did you find out what caused the crash last time?

If you could provide your plan for the current firmware upgrade, include details of the setup and commands then it's easy for us to comment on what you can do differently.

New Contributor
Posts: 3
Registered: ‎02-10-2011

Re: Brocade 5300 upgrade fail

Hi,

Of course. The ftp server is in the same ip range. Here's the firmwareshow output for the systems I have to upgrade:

firmwareshow

Appl     Primary/Secondary Versions

------------------------------------------

FOS      v6.2.1b

         v6.2.1b

firmwareshow

Appl     Primary/Secondary Versions

------------------------------------------

FOS      v6.3.1a

         v6.3.1a

firmwareshow

Appl     Primary/Secondary Versions

------------------------------------------

FOS      v6.2.0b

         v6.2.0b

firmwareshow

Appl     Primary/Secondary Versions

------------------------------------------

FOS      v6.2.0g

         v6.2.0g

@Johan:

Unfortunately I didn't find out what caused it, I just have a tip:

TSB 2010-075-A

(Defect 270261)

When upgrading a DCX, DCX-4S or Brocade 5300 from Fabric OS v6.2.2a or lower to FOS v6.3.1 or 6.3.0c or lower, the Compact Flash (CF) may report an access error. This will cause a reboot of the affected CP within the DCX/DCX-4S or Brocade 5300 to fail.

My upgrade plan is the following:

1) supportsave -c

2) configupload -p ftp

3) firmwaredownload FTP_IP,user,/brcfw/v6.3.2d/release.plist,password

Regular Contributor
Posts: 226
Registered: ‎01-08-2011

Re: Brocade 5300 upgrade fail

"Brocade 5300 from Fabric OS v6.2.2a or lower to FOS v6.3.1 or 6.3.0c or lower,"

So that specific error doesn't apply if you upgrade to 6.3.2b.

New Contributor
Posts: 3
Registered: ‎02-10-2011

Re: Brocade 5300 upgrade fail

I know, but unfortunately I haven't got better tip

During the last upgrade the switch crashed at once when I entered the firmware command - no confirmation question appeared, at all. (whether I'm sure to upgrade or not)

Super Contributor
Posts: 635
Registered: ‎04-12-2010

Re: Brocade 5300 upgrade fail

You should check if you have any tracedumps hanging around on the san switch before you update.

Please read the release notes before you update the switches.

If you have any monitoring application running I would stop running them during the update.

Did you plan to update after that update to the latest 6.4 level?

Regards,

Andreas

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.