Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎07-13-2011

Brocade 24000: CP cards not booting up

Hi,

I am currently working on a Brocade 24000, branded as IBM 2109 M14. The Fabric OS version on the director is 5.0.1b. One of the CP cards developed a problem and is stuck in a loop when it boots. This is what the console port shows during booting:

The system is coming up, please wait...
Read board ID of 0x83 from addr 0x23
Read extended model ID of 0x6 from addr 0x22
Matched board/model ID to platform index 0
Checking system RAM - press any key to stop test
Checking memory address: 00100000
System RAM test using Default POST RAM Test succeeded.
Press escape within 4 seconds to enter boot interface.
Booting "Fabric Operating System" image.
Linux/PPC load:
BootROM command line: quiet
Uncompressing Linux...done.
Now booting the kernel
Attempting to find a root file system on hda2...
modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.19/modules.dep (No such file or directory)
INIT: version 2.78 booting
INIT: Entering runlevel: 3
eth0: Link status change: Link Up. 100 Mbps Full duplex Auto (autonegotiation complete).
eth1: Link status change: Link Up. 100 Mbps Full duplex Manual (forced).
2011/06/13-15:53:37, , 3588,, ERROR, ?, Failed to retrieve current chassis configuration option, ret=-29
2011/06/13-15:53:54, , 3589,, ERROR, ?, Failed to retrieve current chassis configuration option, ret=-29
flushing ide devices: hda
Restarting system.

The above output repeats indefinitely. Thinking that the CP card was defective, I replaced it with another CP card, but apparently this didn't help. Actually, it seems worse. I have no knowledge about the condition of this CP card, nor its firmware version. This is the output I get from the second CP card:

The system is coming up, please wait...
Read board ID of 0x83 from addr 0x23
Read extended model ID of 0x6 from addr 0x22
Matched board/model ID to platform index 0
Checking system RAM - press any key to stop test
Checking memory address: 00100000
System RAM test using Default POST RAM Test succeeded.
Press escape within 4 seconds to enter boot interface.
Booting "Fabric Operating System" image.
loading kernel
loaded at:     01000000 013F9364
board data at: 013F7324 013F7364
relocated to:  01005110 01005150
zimage at:     0100597D 0116B020
initrd at:     0116C000 013F6C00
avail ram:     013FA000 10000000
Linux/PPC load:
BootROM command line: quiet
Uncompressing Linux...done.
Now booting the kernel
PCI: Cannot allocate resource region 0 of device 0000:00:00.0
Installing Linux 2.6 Kernel
Attempting to find a root file sVFS: Can't find ext3 filesystem on dev hda2.
ystem on hda2...
INIT: version 2.78 booting
INIT: Entering runlevel: 3(none)
2011/07/13-20:17:09, , 208,, ERROR, Silkworm, Failed to retrieve current chassis configuration option, ret=-29
2011/07/13-20:17:10, , 209,, ERROR, Silkworm, Failed to retrieve current chassis configuration option, ret=-29
2011/07/13-20:17:10, , 209,, INFO, Silkworm, First failure data capture (FFDC) event occurred.
2011/07/13-20:17:11, , 210,, INFO, Silkworm, First failure data capture (FFDC) event occurred.
Restarting system.

I looked up the SYSM-1004 error and according to the error reference, it's either that the CP card is not seated properly (unlikely), or the WWN card is bad. Any suggestions? Any help will be very, very much appreciated.

Frequent Contributor
Posts: 104
Registered: ‎07-27-2009

Re: Brocade 24000: CP cards not booting up

Replace the WWN card. That one is gone. You will most likly have to reconfigure your box as well unless you have a backup from "configupload".

Cheers

Erwin

PS the 24000 is EOSL (End of service life) You'll be lucky if you find spare parts. Brocade does not support this switch any longer and OEMs just support it for hardware replacements as long as their spare-part stock is not depleted.


My option would be to seriously look at some new gear in-stead of resuscitating a dead horse.

External Moderator
Posts: 4,973
Registered: ‎02-23-2004

Re: Brocade 24000: CP cards not booting up

--->>> Replace the WWN card. That one is gone.

WWN Card replacement required at same time replacement all License, current License Key will not work with another NEW Card.

TechHelp24
New Contributor
Posts: 2
Registered: ‎07-13-2011

Re: Brocade 24000: CP cards not booting up

Thanks much for both replies. Upgraded the firmware in the CP card to match the firmware in the director. Now the only error is:

2011/07/13-20:17:09, , 208,, ERROR, Silkworm, Failed to retrieve current chassis configuration option, ret=-29

Cannot really just go ahead and replac the WWN card because it is a live system. Manual says WWN card failure is very unlikely, too. Checked for bent pins in the backplane, etc. Still cannot figure out what is going on. This is actually an IBM 2109 M14, so it is an IBM-branded Brocade switch. The CP card I am trying to install is Brocade-branded. Do you think it matters? The IBM part number for the CP card is 60-0100922-03, while the part number of the Brocade CP card I have is 250-042-900.

Thanks again

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.