Fibre Channel (SAN)

Reply
Visitor
Posts: 1
Registered: ‎06-05-2017

5100 wont boot: reporting Buffer I/O error on device hda1, logical block 6 hda: drive not ready for command Buffer I/O eHrror on device hda1

[ Edited ]

Hello,

 

Trying to boot brocade 5100 switch which has ssh locked up, won't boot up, now showing:

 


Buffer I/O error on device hda1, logical block 6
hda: drive not ready for command

 

Block count keeps counting up

 

 

 

Booting it finally results in:

 

Swapping shutdown to ;shutdown
Need to insure partition and kernel have ; inside them
Original RootPartition: hda1;hda2
Swapped RootPartition is hda2;hda1
Original OSLoader ATA()0x1a6ff8;ATA()0x849ff
Swapped OSRootPartition: ATA()0x849ff;ATA()0x1a6ff8
The affected filesystem will now be repaired from the backup
Rebooting in 20 seconds.

 

Once booted 2nd time you get;

 

Map file at LBA sector 0x849ff
ATA controller reset failed.
Read map file failedd
Map file at LBA sector 0x1a6ff8

 

Hit ESC to stop autoboot:  0
Map file at LBA sector 0x849ff
ATA controller reset failed.
Read map file failedd
Map file at LBA sector 0x1a6ff8
ATA controller reset failed.
Read map file failedd
do_bootm 171: load_addr 0x00100000 addr 0x00400000
do_bootm 174: ## Booting image at 00400000 load_addr 0x00100000 ...
Bad Magic Number

The system is coming up, please wait...

 

 

Any suggestions? ideas?

 

 

Brocade Moderator
Posts: 302
Registered: ‎03-29-2011

Re: 5100 wont boot: reporting Buffer I/O error on device hda1, logical block 6 hda: drive not ready for command Buffer I/O eHrror on device hda1

Hi,

 

bad drive / flash - you need to get a hardware replacement (switch or motherboard).




If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution".


Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers. All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution"

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.