Fibre Channel (SAN)

Reply
New Contributor
Posts: 4
Registered: ‎10-05-2007

3250 Silkworm Firmware upgrades ?

I have a Silkworm 3250 and Fabric OS of 4.2.0b. I would like to upgrade the firmware and such to the most current version to support Solaris 10 environment.**********************************************************************<BR>READ THE TERMS OF THE AGREEMENT ("AGREEMENT") IN THE LEGAL_LICENSE.TXT<BR>FILE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THE SOFTWARE, YOU<BR>AGREE TO THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE<BR>TERMS, PROMPTLY DESTROY THE UNUSED SOFTWARE.<BR>*********************************************************************<BR><BR>Keywords: brocade 2g 4g fibre channel switch firmware fos 200e 3250 3850 3900 4100 4900 5000 7500 24000 48000<BR>Synopsis: Brocade FOS v5.3.0 patch for 200e 3250 3850 3900 4100 4900 5000 7500 24000 48000<BR>Date: Aug/17/2007<BR><BR><BR>Install Requirements: NA <BR> <BR>Solaris Release: 8 8_x86 9 9_x86 10 10_x86<BR><BR>SunOS Release: 5.8 5.8_x86 5.9 5.9_x86 5.10 5.10_x86<BR><BR>Unbundled Product: Brocade Fibre Channel Switch Firmware<BR><BR>Unbundled Release: N/A<BR><BR>Xref: <BR><BR>Topic: Brocade FOS 5.3.0 firmware release for 200e 3250 3850 3900 4100 4900 5000 7500 24000 48000<BR><BR>Relevant Architectures: sparc i386<BR><BR>BugId's fixed with this patch: <BR><BR>Changes incorporated in this version: <BR><BR>Patches accumulated and obsoleted by this patch: 122185-02<BR><BR>Patches which conflict with this patch: <BR><BR>Patches required with this patch: <BR><BR>Obsoleted by: <BR><BR>Files included with this patch: <BR><BR>LEGAL_LICENSE.TXT<BR>MIBs.zip<BR>README.124898-06<BR>patchinfo<BR>v5.3.0.zip<BR>v5.3.0_releasenotes_v2.0.pdf<BR><BR>Problem Description:<BR><BR>Note: Special Instructions:<BR>----


<BR>v5.3.0 is incompatible with the Brocade 12000 Director. Use v5.0.4a or later for upgrade<BR>on 12000 models. See SunSolve Patch 119552 for the latest available firmware for the SilkWorm 12000.<BR> <BR>IMPORTANT IMPORTANT IMPORTANT<BR>************************************************<BR> The items made available through this website<BR> are subject to United States export laws and<BR> may be subject to export and import laws<BR> of other countries. You agree to strictly comply<BR> with all such laws and obtain licenses to<BR> export, re-export, or import as may be required.<BR> Unless expressly authorized by the United States<BR> Government to do so you will not, directly or<BR> indirectly, export or re-export the items made<BR> available through this website, nor direct the<BR> items therefrom, to any embargoed or restricted<BR> country identified in the United States export<BR> laws, including but not limited to the Export<BR> Administration Regulations (15 C.F.R. Parts<BR> 730-774).<BR>*************************************************--
<BR> <BR>This is not an OS patch and is not installed with the standard Solaris <BR>patchadd(1M) command. After unpacking the patch, follow the "Special Install <BR>Instructions" below to upgrade the FC switch firmware.<BR> <BR>Brocade FOS 5.3.0 firmware release for 200e 3250 3850 3900 4100 4900<BR>5000 7500 24000 48000. To install using other platforms, minimum FTP services <BR>is required. Please see Brocade document 53-1000448-01.<BR> <BR> <BR>Prerequisites for installing the new firmware include:<BR> <BR> * FTP server (solaris host).<BR> <BR> * An Ethernet connection from a Solaris host to the Brocade Switch. To use an <BR> Ethernet connection, the Brocade FC switch must have an IP address assigned<BR> and the user must know the admin password assigned to the switch.<BR> <BR>Unpack the patch into any convenient directory such as /var/tmp, and refer to <BR>the Special Install Instructions below.<BR><BR>Special Install Instructions:<BR>

<BR>Sun supports firmware upgrades within two feature releases (a feature<BR>release is a major release indicated by the<BR>second digit "Y" of the release number, for example, X.Y.Z); while<BR>upgrades of two releases is supported, single<BR>release upgrades are recommended. Following are the major upgrade<BR>versions for the Fabric OS:<BR>- v4.0x<BR>- v4.1x<BR>- v4.2x<BR>- v4.4x<BR>- v5.0x<BR>- v5.1x<BR>- v5.2x<BR>- v5.3x"<BR><BR> <BR>This firmware upgrade procedure will not cause I/O interruption if using FW <BR>v4.1.0 or greater.<BR> <BR> <BR> 1. Change your working directory to the directory in which the patch<BR> was saved. Then unzip the firmware file, v5.3.0.zip. <BR> and confirm that the v5.3.0 directory is present.<BR> Do not link release.plist in this directory.<BR> <BR> 2. Invoke telnet using the following syntax:<BR> <BR> telnet <hostname><BR> <BR> where <hostname> is the name or IP address of the FC switch. If security<BR> is enabled, you will need sectelnet application or ssh. <BR> <BR> <BR> 3. Verify that the current switch firmware by typing the<BR> following command at the "admin>" prompt:<BR> <BR> version<BR> <BR>EXAMPLE:<BR> sw0:admin> version<BR> Kernel: 2.4.19<BR> Fabric OS: v5.0.3 <
- be restarted. Do you want to continue : y firmwareshow
Primary partition: v5.3.0
Secondary Partition: v5.3.0

24000/48000 EXAMPLE:
switch:admin> firmwareshow

Slot Name Primary/Secondary Versions Status
]]>
--
<BR>5 CP0 v5.3.0 Standby<BR> v5.3.0<BR> <BR>6 CP1 v5.3.0 Active *<BR> v5.3.0<BR> <BR> <BR>Reference<BR>
--


External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: 3250 Silkworm Firmware upgrades ?

By Upgrade from Old FabOS 4.2.x you must upgtrade in more step.If you not upgrade inmore step get a risk to damaged the Compact Flash in the Switch.

TechHelp24
New Contributor
Posts: 4
Registered: ‎10-05-2007

Re: 3250 Silkworm Firmware upgrades ?

Thought someone might say that.. thank you &lt;!graemlin::)&gt;If you not upgrade inmore step get a risk to damaged the Compact Flash in the Switch.

External Moderator
Posts: 5,029
Registered: ‎02-23-2004

Re: 3250 Silkworm Firmware upgrades ?

Hi,

TechHelp24
New Contributor
Posts: 4
Registered: ‎10-05-2007

Re: 3250 Silkworm Firmware upgrades ?

Thank you ... will try and do upgrades

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook