For more details, please see ourCookie Policy.


Fibre Channel (SAN)

Reply
New Member
Posts: 1
Registered: ‎04-25-2018

getting "Options are invalid" when run the command "snmpconfig --disable snmpv1"

We need to disable snmpv1 due to mentioned vulnerability on SAN switch 320.

 

Vulnerabilitie:-

CVE-1999-0517
Risk 7.5 High
udp 161
SNMP Agent Default Community Name (public)

 

FOS details:-

Kernel: 2.6.14.2
Fabric OS: v6.4.3d
Made on: Fri Feb 22 21:56:26 2013
Flash: Mon May 12 13:31:42 2014
BootProm: 1.0.9

 

here is the result when run the command to disable snmpv1.

 

XXXXXX:yyyy> snmpconfig --disable snmpv1
Options are invalid

 

Will somebody guide us, how can we disable snmpv1?

 

Thanks

Manoj Kumar

 

 

Regular Contributor
Posts: 179
Registered: ‎04-04-2018

Re: getting "Options are invalid" when run the command "snmpconfig --disable snmpv1"

Hello,

 

there is no possibility to disable snmpv1 

 

https://community.brocade.com/t5/Fibre-Channel-SAN-Forums/disable-snmpv1-on-brocade-5300/td-p/32727

 

You may change comunity string from public to something different. Use command bellow and once you will be prompted to change  public Community (ro): [public], change word public to something different.

 

snmpconfig --show snmpv

Then if you like, you may disable mib capability.

Please mark this response as "Accept as Solution" if it answers your question.

Marian Bezeg

Join the Broadcom Community

Get quick and easy access to valuable resources across the Broadcom Community Network.