For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Occasional Contributor
Posts: 13
Registered: ‎03-13-2015

Upgrade 7.2.1 -> 7.3.1

I have a couple of 6510s that are running 7.2.1 that I would like to get to 7.3.1 - I'm using a Mac and have download both the windows ZIP and the Linux GZ file


I've ssh'd to the system, and when I run firmwaredownload, it failes with:


Failed to access scp://username:*********@xx.xx.xx.xx//Brocade/firmware/v7.3.1/release.plist


That file doesn't exist at that level, though there are a lot of them in the SWBDXX(X) directories.


Any ideas on how to proceed?



Occasional Visitor
Posts: 1
Registered: ‎03-13-2015

Re: Upgrade 7.2.1 -> 7.3.1

[ Edited ]


External Moderator
Posts: 5,510
Registered: ‎02-23-2004

Re: Upgrade 7.2.1 -> 7.3.1



I believe you confuse them Brocade with other vendors.

the instructions you posted incl. the FW details you mention, are related to QLOGIC SAN Switches, and not Brocade SAN Switches.


For this reason, I'll remove the content.

External Moderator
Posts: 5,510
Registered: ‎02-23-2004

Re: Upgrade 7.2.1 -> 7.3.1

hi agehring,


release.plist is a part of firmwaredownload command and not visible in root folder, however is not mandatory to executed the upgrade with the ending /release.plist


additional, make sure you FTP Server or in you case SCP is correct configured and you have full access.


start the firmwaredownload again and point as File folder to example:


/v7.x.x./release.plist or v7.x.x


in some circumstance is "/" not required



Senior Member
Posts: 1
Registered: ‎03-27-2015

Re: Upgrade 7.2.1 -> 7.3.1

[ Edited ]

Hi agehring.

I had already this problem and didn't find a lot of information about.

I upgraded today my SAN 300 from FOS 7.0.1 to FOS 7.3.1a.

So I want to publish my small manual how to make FOS update on Brocade San 300 and his clones:


1. Download FOS from MyBrocade.

2. Unzip it.

3. Install ftp server, I used TYPsoftFTP.

4. Place unzipped FOS on your FTP server. You must have one folder v7.3.1a with many subfolders SWBDxxx.

5. Open telnet session to your switch and login with admin.

6. Input firmwaredownload -s

7. Type IP of FTP-server

8. Type login of FTP

9. Type Folder as it was unzipped v7.3.1a/ with slash in the end. You don't need to choose version.plist.

10. Choose connection type AUTO

11. Type password of FTP.

12. Apply firmware after reboot? - Yes

13. Reboot switch after firmware download? - No


If your FTP-server is working properly begins firmware update. If you lost more then 2 releases of FOS (for example from 7.0.1 to 7.3.1), the system will say it. I made it from 7.0.1 to 7.1.0 first. Then from 7.1.0 to 7.3.1a.


Normaly after upgrading FOS you must reboot your switch.

To apply new firmware ONLINE without rebooting type HAREBOOT

The new FOS will be accepted without reboot.


So, you can answer, if you still have questions.

New Contributor
Posts: 2
Registered: ‎03-29-2012

Re: Upgrade 7.2.1 -> 7.3.1

I am having this same problem.  I had previously upgraded two B300 switches through two upgrades (7.2 to 7.4) while I was onsite with the switches on a private network using FileZilla server on my laptop.  Straight up FTP.  Now we have two new B300s and using a local management server that is on the same network as the switches, even plugged into the same network switch.  I have tried a variety of FTP servers doing straight up FTP and I always get the "release.list" error.  I am using the same files for the upgrade in the same folder structure as before.   I can access the FTP server from the switches to store switch configuration files, and I can access the FTP server to push files from other systems that can see that subnet.  In monitoring the messages that appear in the FTP server watch window, I can see the process moving into the proper directory (SWBD71) that contains the FW for the B300.  In my last attempt, I even downloaded the very FTP server recommended, configured my login and file access setup and still failed.  Any assistance, thoughts, chants or other approaches would be welcome. 

Broadcom Moderator
Posts: 467
Registered: ‎03-29-2011

Re: Upgrade 7.2.1 -> 7.3.1

Hi Larry,


Are you able to ping the ftp server from the switch when logged in as root? 

If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution".

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers. All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution"

Join the Broadcom Community

Get quick and easy access to valuable resources across the Broadcom Community Network.