For more details, please see ourCookie Policy.

Fibre Channel (SAN)

New Contributor
Posts: 4
Registered: ‎07-18-2011

Network Advisor discovery problem

I'm curious if anyone has run into this before.  I'm getting the following error when trying to discover a new switch in Network Advisor. certificate does not conform to algorithm constraints.

This is happening on two different switches that we had to replace.  They are IBM FC5022 switches installed in an Enterprise Flex Chassis.  Functionally, I believe they are very similar to Brocade 6510s but are obviously a different form factor.  BOTH of the new switches are getting this same error.  They are each ISL'd to another switch.  I tried many various discovery methods in Network Advisor, but not of them worked.  I created a new user/password and that didn't work either.  I tried deleting the old fabric and added all of the switches one at a time prior to connecting the ISL and still had the same issue.  I tried using different SNMP options, but nothing helped. _ I can't find any Brocade doc that talks about this.  If anyone has ideas, please share!  Thanks!

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Network Advisor discovery problem


try resetting the snmpconfig in the switchs: snmpconfig --defaults snmpv3.

External Moderator
Posts: 5,540
Registered: ‎02-23-2004

Re: Network Advisor discovery problem


AFAIK, FC5022 cannot be discover as seed-switch, that mean you must discover the switch where the FC5022 is ISL.

Second, make sure the FC5022 IP is not behind by firewall.

Posts: 23
Registered: ‎03-08-2007

Re: Network Advisor discovery problem


from the FC5022 check "ipfilter --show" output to ensure tcp ports 23 and 80 are not denied for ipv4 or ipv6



Join the Broadcom Community

Get quick and easy access to valuable resources across the Broadcom Community Network.