For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 34
Registered: ‎03-02-2010

Firmware Upgrade Halts When Upgrading From v6.1.0 To v6.2.2b on Switch DS-4100B

Problem Description


Firmware Upgrade Halts When Upgrading From v6.1.0 To v6.2.2b on Switch DS-4100B

Firmware upgrade halts displaying the following error message

Finished writing kernel image.
Removing unneeded files, please wait ...
Firmwaredownload timed out.
Firmware download failed - Firmware download timed out. (0x23)
2010/10/16-13:03:57, , 50493,, INFO, mmel1c03bs0, Previous message repeated 7 time(s)
2010/10/16-13:07:40, , 50494,, INFO, DS_4100B, Firmwaredownload command failed. Firmware download timed out.
mmel1c03bs0:tmpadmin> 2010/10/16-13:07:42, , 50495,, INFO, mmel1c03bs0,LOCL Clock Server used instead of External: locl: 0x45585400 remote: 0x4c4f434c

Now if firmwareshow is executed, found that the primary partition still has firmware v6.10 and the secondary partition displays unknow. Hence i did do a

' firmwarecommit ' to get the secondary partition In Sync with the primary. ..WorkedFine. Now Switch back to firmware v6.1.0. Did run the ' tsclockserver ' found the active NTP server & configured NTP server to be the same ' '. Did reboot the switch and initiated the firmwaredownload again.. ...No-go, as the upgrade is halted at the same stage with the same error. Did telnet to the switch did make sure enough space is available.

mmel1c03bs0:root> df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 242104 113672 115936 50% /
/dev/hda2 241648 99680 129496 43% /mnt

Did login to the switch as the root,made sure that the ' http.enabled:1 & http.ssl.enabled:0 ' were @correct settings.

Did initate the download again. .No-Go

Please Note That This Download Is Been Carried out via Console port, have tried via telnet as well

Please Advise



Super Contributor
Posts: 260
Registered: ‎04-09-2008

Re: Firmware Upgrade Halts When Upgrading From v6.1.0 To v6.2.2b on Switch DS-4100B

Hi Chetan,

Although I'm not 100% sure what the problem could be, the error "Firmware download timed out. (0x23)" occurs usually due to incorrect duplex setting on the switch. Sometimes this is due to the cable between your laptop and switch if they are directly connected during the upgrade.

To fix this problem you need to set the switch mgmt interface to 100 Mbps Full duplex, using the following command.

ifmodeset "eth0"

Join the Broadcom Community

Get quick and easy access to valuable resources across the Broadcom Community Network.