Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎09-19-2012

Communication Issues at 8GB. Works Great at 4GB

Looking for some advise as where to start troubleshooting this issue. This is a new setup.

The Setup. Primary Data Center SAN Connected to a two Brocade 300 switches. One port on the one switch has a Brocade 8GB 10Km Sfp purchased. At the Secondary Data Center we have a Single Brocade 300 switch with a attached SAN which also has a Brocade 8GB <10KM SFP.There is a dark fibre link that connects both of these together. There is no switching in between these at all, with the exception of a couple patch panels. The distance between the two sites is 4Km. When the Ports are set at 8GB(AutoNeg) or Hard Coded, I can move data, but its very very slow. 20MB/Sec. I see alot of CRC errors and invalid Transmited Word and started seeing a Warning on the Destination Brocade switch "Severe latency bottleneck detected at slot 0 port 7". YEs port 7 is the 10Km link. Also, around the same time the SAN links had flapped and had this same "Invalid Transmitted word type".  Was suggested I run the following two commands on both sides.

portcfgfillword <PORT> 3

portcfglongdistance <PORT> LE 1

CRC ERORRS went away but still had "Invalid transmitted word type" and the same lack of speed. 20MB/SEC. Had coded one side too 4GB and the other side picked up the 4GB link. Cleared counters. And transfered 1TB of data accross the link. Was super nice. 100MB +/sec moving data. Where too start? Any Ideas?

Thanks .
 
 
 





Regular Contributor
Posts: 226
Registered: ‎01-08-2011

Re: Communication Issues at 8GB. Works Great at 4GB

Hi, you could experiment with the other settings on portcfgfillword - at least with end-devices it's not always the same setting.

Do you have 8Gb end-devices too? Perhaps you need to configure proper fill-word there too.

In the CMD reference it says that if you use QoS you should not use vc_init (the 1 in your portcfglondistance command).

New Contributor
Posts: 2
Registered: ‎09-19-2012

Re: Communication Issues at 8GB. Works Great at 4GB

The end devices are SAN Fibre connections which are 8GB as well. I never did set any setting on those ports as i figured those were suppose to work right out of the box. Maybe I assumed wrong.

New Member
Posts: 1
Registered: ‎04-19-2018

Re: Communication Issues at 8GB. Works Great at 4GB

Did you manage to solve the problem? We are experiencing the same issue with the ISL, but cant figure out why. We changed, the SPFs and the patchcord, but it didnt work.

Occasional Contributor
Posts: 19
Registered: ‎03-20-2018

Re: Communication Issues at 8GB. Works Great at 4GB

On both switches, run porterrshow and sfpshow -all | grep -e Port -e Power

 

Post the ports that you suspect are having problems.

Contributor
Posts: 49
Registered: ‎04-04-2018

Re: Communication Issues at 8GB. Works Great at 4GB

As you mentioned you are receiving "Invalid transmitted word type" which means that you have wrong fill world settings.

Please past ouput of portcfgshow slot/port command.

Please mark this response as "Accept as Solution" if it answers your question.

Marian Bezeg
Contributor
Posts: 49
Registered: ‎04-04-2018

Re: Communication Issues at 8GB. Works Great at 4GB

There may be problem with fill world.

Please past oupurt of portcfgshow slot/port for ISL links.

Please mark this response as "Accept as Solution" if it answers your question.

Marian Bezeg
Contributor
Posts: 49
Registered: ‎04-04-2018

Re: Communication Issues at 8GB. Works Great at 4GB

It looks like that there is problem with fill world settings.

Could you please past output of portcfgshow slot/port ?

Please mark this response as "Accept as Solution" if it answers your question.

Marian Bezeg
Regular Visitor
Posts: 1
Registered: ‎04-20-2018

Re: Communication Issues at 8GB. Works Great at 4GB

Change the fillword to 3 on the connected ports.
Contributor
Posts: 49
Registered: ‎04-04-2018

Re: Communication Issues at 8GB. Works Great at 4GB

Please paste output of porcfgshow slot/port for ISL connections.

 

Please mark this response as "Accept as Solution" if it answers your question.

Marian Bezeg

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.