Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎03-04-2013

VLAN interoperate with Cisco 2950

This is probably a fairly easy questions but I'm rather new to brocade switches; especially this one.

Here's my setup Cisco 1800 series router < - > Brocade 6910 switch  < - > Cisco 2950 switch < - > rest of LAN

I've done similar setups many times without the brocade componet. I want to configure a new vlan 9 in this case. I want to be able to traverse the 6910 switch. I'm not able to get the 6910 and the 2950 to trunk together. I've turned off negitation on the 2950 and set it to trunk. I've configured the ports on the 6910 to trunk but to no avail. I believe the trunk between the router and the 6910 is working as I can ping the VLAN 9 addresses from one another. I cannot ping the VLAN 9 address of the 2950 from either device nor do downstream devices get DHCP addresses from the router.

My 6910 is running 2.0.2.7 here is the relevant config

vlan database

VLAN 1 name DefaultVlan media ethernet state active

VLAN 9 name New_VLAN media ethernet state active

!

....

!

interface ethernet 1/5

description to 2950

switchport allowed vlan add 1 untagged

switchport mode trunk

switchport allowed vlan add 1,9 tagged

vlan-trunking

!

same settings for eth 1/2 that goes to the router

and on the 2950

!

interface GigabitEthernet0/2

switchport trunk pruning vlan none

switchport mode trunk

switchport nonegotiate

!

The operational mode of the port on the 2950 shows trunk.

Any ideas?

jdb
Occasional Contributor
Posts: 5
Registered: ‎06-23-2009

Re: VLAN interoperate with Cisco 2950

This is just an idea but have you actually tried to force using the IEEE encapsulation protocol (dot1q)?

interface GigabitEthernet0/2

description PORTDESCR

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,105

switchport mode trunk

switchport nonegotiate

Here you go with an example for a WS-C3560G-24TS-S running 122-50.SE5:

User Access Verification

Password:

Coreswitch>enable

Password:

Coreswitch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

switch(config)# interface G0/2

switch(config-if)# switchport trunk encapsulation dot1q

switch#write memory

Building configuration...

switch# copy running-config startup-config

Destination filename ? 

Building configuration...

switch# show configuration

New Contributor
Posts: 2
Registered: ‎03-04-2013

Re: VLAN interoperate with Cisco 2950

The 2950 doesn't show the encap option on the interface switchport command. I did look at the current config via sho int g0/2 and it shows the operational trunking encapsulation as 802.1q. If I'm not mistaken I believe that is the only encap supported by the 2950 series.

Any other ideas? It's gotta be something small I'm missing. I've got my Brocade SE looking at it also and he doesn't see anything wrong either.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook