Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 6
Registered: ‎01-07-2011

Trunk mode like switchport mode trunk

Hello all,

Iam newbie with brocade switches, i have 4x FWS624G switch.

Sorry for this stupid question, but Iam not able setup port asi trunk (used for uplink with other switch), after reading this

huge manual ( http://www.brocade.com/downloads/documents/product_manuals/B_FastIron/fastiron-07200-config-guide.pdf) Iam

confused, there is something about Trunk groups, but nothing about trunk ports.

(alse "show interface brief" still showing Trunk None).

He is simple configuration in CISCO language

(uplink port - mode trunk with allowed vlan 1,101...)

interface FastEthernet0/12
description UPLINK
switchport trunk allowed vlan 1,101,1002-1005
switchport mode trunk
( access port - vlan 101, connected SIP phone)
interface FastEthernet0/9
description VOIP
switchport access vlan 101
spanning-tree portfast
no cdp enable
---
How can i setup trunk port od Brocade switches(FWS624G).
I try
vlan 1 name DEFAULT-VLAN by port
!
vlan 101 name voip by port
tagged ethe 0/1/23 to 0/1/24
also untagger directive, uplink directive, but notthing work.
Thx for help. FH
Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Trunk mode like switchport mode trunk

Hi Havel,

     VLAN 1 is reserved for the system as the default VLAN - do not use please. (If you do need to use VLAN 1 then change the default VLAN to some other number).

So for say 3 VLAN's (101,102 and 103) from the config term level.

vlan 101

tag eth 0/1/23 to 0/1/24

vlan 102

tag ether 0/1/23 to 0/1/24

vlan 103

tag eth 0/1/23 to 0/1/24

and you are done.

Thanks

Michael.

Occasional Contributor
Posts: 6
Registered: ‎01-07-2011

Re: Trunk mode like switchport mode trunk

Thanks you very much, few minutes after this post I find same solution, so

untagged ports = access ports -> simple say connect client computer

tagged ports    = trunks ports   -> simple say connect between switches

And  native vlan could by probably set by command "default-vlan-id vlanid", default is 1.

Thx a lot, iam moving to STP a then PVSTP testing. F.

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Trunk mode like switchport mode trunk

You are correct - tag = swich ports, untag = access.

STP,RSTP and MSTP should be no issue- same for PVSTP+

and yes that is the command to change the default VLAN.

New Contributor
Posts: 3
Registered: ‎06-09-2010

Re: Trunk mode like switchport mode trunk

You don't even have to change the default for the native vlan -- just make that port untagged for that vlan.

cisco:

on port 3's config (loosely -- do not try these commands based on this here!)

switchport mode trunk

switchport trunk vlan allowed 101,102,103

switchport trunk native vlan 102

turboiron:

vlan 101 tagged eth 3

vlan 103 taggged eth 3

vlan 102 unt eth 3

Occasional Contributor
Posts: 14
Registered: ‎02-02-2011

Re: Trunk mode like switchport mode trunk

I found my problem configuring the tagging (Cisco Trunk) after following these simple instructions over and over again was that the Cisco Trunk did not  work correctly. I removed the "switchport trunk native vlan" on my Cisco switch to fix the problem.

"Notes: In some situations, like connecting to a Cisco ® device or VoIP device, traffic may appear on an interface both tagged and untagged. For example, Cisco native vlan will not have a VLAN tag on a Cisco 802.1Q link. A port that is dual-mode, will send/receive untagged packets and place it into the appropriate VLAN while also accepting normal tagged traffic"

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Trunk mode like switchport mode trunk

Oh I see, Thanks for the information Charles.

So Cisco native vlan = brocade Dual-mode port.

Dual-mode VLAN ports

Configuring a tagged port as a dual-mode port allows it to accept and transmit both tagged traffic  and untagged traffic at the same time. A dual-mode port accepts and transmits frames belonging to VLANs configured for the port, as well as frames belonging to the default VLAN (that is, untagged

traffic).

e.g.

FastIron(config)# vlan 20

FastIron(config-vlan-20)# tagged ethernet 2/11

FastIron(config-vlan-20)# tagged ethernet 2/9

FastIron(config-vlan-20)# interface ethernet 2/11

FastIron(config-if-e1000-2/11)# dual-mode

FastIron(config-if-e1000-2/11)# exit

So if you still needed to use the Cisco native vlan then you must set the connecting Brocade port as Dual-mode.

Thanks

Michael.

Occasional Contributor
Posts: 14
Registered: ‎02-02-2011

Re: Trunk mode like switchport mode trunk

But if your tagging more than 2 Vlans over an interface the dual-mode won't work. I am working on this now with a router connected. My Cisco ASA is where I had to remove the native VLAN. On my Cisco router (Call Manager Express & Wirless) I have 3 VLAN's that I need to tag:

Router (UC520):

interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch

FWS648G

interface ethernet 0/1/47

3 Vlan's are Tagged: 100, 130, 200

No Dual-Mode

Can't get vlan 200 to pass traffic. I'm going to open a TAC case with Cisco. I'm confident something's wrong on that side.

I do have a routing issue too, probably for a seperate post.

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Trunk mode like switchport mode trunk

Hi Charles,

     How did you go?

Thanks

Michael.

Broadcom
Posts: 10
Registered: ‎06-01-2011

Re: Trunk mode like switchport mode trunk

But if your tagging more than 2 Vlans over an interface the dual-mode won't work.

This is NOT true !

Just tag these 2 vlans on the specific port. Then go to the port config and configure "dual-mode 1" !

With this command all untagged traffic on this port is forwarded to vlan 1 and its then fully compatible to other vendors who always transport the default vlan additionally untagged on an uplink port.

The IEEE 802.1q standard allows both versions for tagged uplinks.

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook