Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 8
Registered: ‎03-28-2013

Strange Dropped ICMP

I'm pinging an interface on an MLXe from another router on a directly connected interface and it receives the echo requests, but appears to be dropping the TX echo replies, with the reason, "Route-only enabled(CV)". It's a simple VE interface associated with a tagged VLAN on a switched port, that isn't set to route-only.

interface ethernet 4/1

enable

Here's the packet capture from the line card:

7081.0515.1208 -> Broadcast     

**********************************************************************

ACTION: Drop packet(reason: Route-only enabled(CV))

: Packet received

Time stamp : 21 day(s) 17h 54m 11s:,

TM Header:

Type: Fabric Unicast(0x00000008) Size: 86 Parity: 0 Src IF: 0

Src Fap: 6 Dest Port: 0  Src Type: 0 Class: 0x00000000

**********************************************************************

Packet size: 80, XPP reason code: 0x00007c7c

00: 06f0 000f 5050 0c0a-2413 ffa4 0000 0000  FID     = 0x06f0

10: ffff ffff ffff 7081-0515 1208 8100 0c0a  Offset  = 0x10

20: 0806 0001 0800 0604-0001 7081 0515 1208  VLAN    = 3082(0x0c0a)

30: 0a63 2cf3 0000 0000-0000 0a63 2cf1 0000  CAM     = 0x9ffd2(L)

40: 0000 0000 0000 0000-0000 0000 0000 0000  SFLOW   = 0

50: 0000 abcd abcd abcd-abcd abcd abcd abcd  DBL TAG = 0

60: abcd abcd abcd abcd-abcd abcd abcd abcd

70: abcd abcd abcd abcd-abcd abcd abcd abcd

Pri CPU MON SRC   PType US BRD DAV SAV DPV SV ER TXA SAS Tag MVID

0   0   0   4/1   f     0  1   0   1   0   0  0  0   0   1   0

7081.0515.1208 -> Broadcast     

**********************************************************************

ACTION: Drop packet(reason: Route-only enabled(CV))

: Packet received

Time stamp : 21 day(s) 17h 54m 13s:,

TM Header:

Type: Fabric Unicast(0x00000008) Size: 86 Parity: 0 Src IF: 0

Src Fap: 6 Dest Port: 0  Src Type: 0 Class: 0x00000000

**********************************************************************

Packet size: 80, XPP reason code: 0x00008181

00: 06f0 000f 5050 0c0a-2413 ffa4 0000 0000  FID     = 0x06f0

10: ffff ffff ffff 7081-0515 1208 8100 0c0a  Offset  = 0x10

20: 0806 0001 0800 0604-0001 7081 0515 1208  VLAN    = 3082(0x0c0a)

30: 0a63 2cf3 0000 0000-0000 0a63 2cf1 0000  CAM     = 0x9ffd2(L)

40: 0000 0000 0000 0000-0000 0000 0000 0000  SFLOW   = 0

50: 0000 abcd abcd abcd-abcd abcd abcd abcd  DBL TAG = 0

60: abcd abcd abcd abcd-abcd abcd abcd abcd

70: abcd abcd abcd abcd-abcd abcd abcd abcd

Pri CPU MON SRC   PType US BRD DAV SAV DPV SV ER TXA SAS Tag MVID

0   0   0   4/1   f     0  1   0   1   0   0  0  0   0   1   0

Any thoughts as to why it's dropping the packet?

Contributor
Posts: 61
Registered: ‎12-08-2009

Re: Strange Dropped ICMP

Hi Mike,

As far as know netiron device interfaces are set to route-only by default.

you can try
no route-only
command under interface context and see the result.

Here is the information from the configuration guide:

Enabling or disabling layer 2 switching

By default, Brocade devices supports routing over layer 2 switching. You can enable layer 2

switching globally or on individual port using the no route-only command.

NOTE

On the Brocade NetIron CES and Brocade NetIron CER, the route-only command should not be

configured on untagged MPLS uplinks when using it for VPLS or VLL. Otherwise, incoming VPLSor

VLL traffic is dropped.

The no route-only and route-only commands prompts you for whether or not you want to change the

“route-only” behavior. You must enter y if you want to proceed or n if you do not. The prompt is

displayed as shown in the following examples of the no route-only and route-only commands.

NOTE

Always perform a reload after removing a route-only config or enabling route-only. Removing or

enabling the route-only option without a reload will cause multicast issues.

To enable Layer 2 switching globally, enter the following.

Brocade(config)# no route-only

This will change the route-only behavior at the global level.

Are you sure? (enter ‘y’ or ‘n’): y

Global ‘route-only’ committed.

To globally disable Layer 2 switching on a Brocade device and return to the default (route-only)

condition, enter commands such as the following:

Brocade(config)# route-only

This will change the route-only behavior at the global level.

Are you sure? (enter ‘y’ or ‘n’): y

Global ‘no route-only committed.

Syntax: route-only

NOTE

On the Brocade NetIron XMR and Brocade MLX series devices, route-only is the default condition.

Because route-only is the default condition, it will not be displayed in the configuration. If you use no

route-only to enable switching, the no route-only command will be displayed in the configuration.

NOTE

On the Brocade NetIron CES device, route-only is disabled by default. Therefore, if route-only is

enabled on a Brocade NetIron CES device, it will be displayed in the configuration.

To enable Layer 2 switching only on a specific interface, go to the Interface configuration level for

that interface, and add the no route-only command. The following commands show how to enable

Layer 2 switching on port 3/2.

Brocade(config)# interface ethernet 3/2

Brocade(config-if-e10000-3/2)# no route-only

Syntax: route-only

To re-enable the default route-only condition on port 3/2, enter the route-only command as shown.

Brocade(config-if-e10000-3/2)# route-only

The default route-only condition, unknown unicast packets are not sent to the CPU and are dropped

locally by the hardware.

Hope this helps,

Serhat

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook