Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎08-08-2011

Static DHCP Lease for VLAN's

Hi People,

I have my FWS configured up for DHCP in each VLAN (not the default one thou).

Is there a way to statically map a dhcp lease to a mac address for a given VLAN ?

Cheers,

CONFIG Below.

FWS624G Router>


vlan 50 name IT-VLAN-50 by port
untagged ethe 0/1/6 to 0/1/9
router-interface ve 50
!
vlan 100 name TestVL-100 by port
untagged ethe 0/1/10 to 0/1/13
router-interface ve 100
!
vlan 101 name TestVL-101 by port
untagged ethe 0/1/14 to 0/1/17
router-interface ve 101
!
vlan 102 name TestVL-102 by port
untagged ethe 0/1/4 ethe 0/1/18 to 0/1/21
router-interface ve 102
!
vlan 4095 name DEFAULT-VLAN by port
!
ip dhcp-server pool vlan-100
dhcp-default-router 192.168.100.1
dns-server 192.168.1.1 192.168.1.2
domain-name test.com
excluded-address 192.168.100.2 192.168.100.100
lease 1 0 0
network 192.168.100.0 255.255.255.0
deploy
!
!
ip dhcp-server pool vlan-101
dhcp-default-router 192.168.101.1
dns-server 192.168.1.1 192.168.1.2
domain-name test.com
excluded-address 192.168.101.2 192.168.101.100
lease 1 0 0
network 192.168.101.0 255.255.255.0
deploy
!
!
ip dhcp-server pool vlan-102
dhcp-default-router 192.168.102.1
dns-server 192.168.1.1 192.168.1.2
domain-name test.com
excluded-address 192.168.102.2 192.168.102.100
lease 1 0 0
network 192.168.102.0 255.255.255.0
deploy
!
!
ip dhcp-server pool it-vlan-50
dhcp-default-router 192.168.50.1
dns-server 192.168.1.1 192.168.1.2
domain-name test.com
excluded-address 192.168.50.2 192.168.50.100
lease 1 0 0
network 192.168.50.0 255.255.255.0
deploy
!
ip dns domain-name test.com
ip dns server-address 192.168.1.1 192.168.1.2

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!
no telnet server
snmp-server community ..... ro
snmp-server community ..... rw
snmp-client 192.168.1.3
no web-management hp-top-tools
no web-management http
no port bootp
router rip
redistribution
!
interface ethernet 0/1/5
ip address 192.168.1.4 255.255.255.0
ip rip v2-only
ip rip learn-default
!
interface ve 50
ip address 192.168.50.1 255.255.255.0
ip rip v2-only
!
interface ve 100
ip address 192.168.100.1 255.255.255.0
ip rip v2-only
!
interface ve 101
ip address 192.168.101.1 255.255.255.0
ip rip v2-only
!
interface ve 102
ip address 192.168.102.1 255.255.255.0
ip rip v2-only

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Static DHCP Lease for VLAN's

Hi xcode,

     As far as I can see DHCP reservations are not supported by the DHCP server on the FastIrons.

Thanks

Michael.

New Contributor
Posts: 2
Registered: ‎08-08-2011

Re: Static DHCP Lease for VLAN's

Hey Michael,

Thanks for the responce.

Oh well, i'll stick with some manually assigned client addresses (hence the excluded range in each VLAN).

Regards,

Lee.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook