Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 18
Registered: ‎03-28-2013

NI-MLX-10Gx8-D

Hi everyone,

I'm trying to power on this module in the NetIron MLX-8 and I got this result.

NetIron MLX-8 Router#show module

        Module                             Status      Ports  Starting MAC

M1 (left): NI-MLX-MR Management Module     Active

M2 (right):

F1: NI-X-HSF Switch Fabric Module         Active

F2: NI-X-HSF Switch Fabric Module         Active

F3:

S1: Powered Off (Not Enough Power)

S2: NI-MLX-10Gx2 2-port 10GbE Module  CARD_STATE_UP    2     748e.f85e.a330

S3:

S4:

S5:

S6:

S7:

S8:

NetIron MLX-8 Router#power-on lp 1

Warn:Unrecognized card type in slot 1.Board class: 0x03,Version: 5.3.0

This module may require a later version of code, please refer to release notes.

Could not get power usage for slot 1. It will not be powered on.

Slot 1 is already powered off.

Can someone show me where I can download the right software for this card?  I've looked on Brocade.com but I couldn't find anything.  Thank you in advance.

Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: NI-MLX-10Gx8-D

Greetings huy1.  Firmware downloads are hosted on the Brocade support portal known as "mybrocade".  The link to mybrocade is https://my.brocade.com/.  Once logged in, you can navigate to "downloads" then select "IP/MPLS Routers and Switches".  From there, simply select the corresponding product which you are attempting to download for.

Please note, log-in credentials are required for mybrocade. 

Regards,

Mike Eversole
Brocade Community Manager
Frequent Contributor
Posts: 160
Registered: ‎08-07-2009

Re: NI-MLX-10Gx8-D

You appear to be at a supported firmware version for the 8x10G-D module. 8x10G-d is supported on 5.0b and above.

You also have the required High Speed Switch Fabrics installed which is a requirement with the 8x10G. I would try re-seating

the module and /or try a different slot just as a troubleshooting process. Beyond that you will probably need to contact support.

-Bill

Occasional Contributor
Posts: 18
Registered: ‎03-28-2013

Re: NI-MLX-10Gx8-D

Thanks Mike and Bill for the reply.  However I've re-seating the module multiple times.  I've moved it to a different slot.  I'm still getting the same error message.  What do you think I should try next?

Huy

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: NI-MLX-10Gx8-D

Can you post a show ver?

The card has 5.3, but what is the system running?

Occasional Contributor
Posts: 18
Registered: ‎03-28-2013

Re: NI-MLX-10Gx8-D

Hi Michael,

Here is the show ver:

NetIron MLX-8 Router>sh ver

System Mode: MLX

Chassis: NetIron 8-slot (Serial #: A62742GKX4,  Part #: 35549-001)

NI-X-HSF Switch Fabric Module 1 (Serial #: BEU0334F065,  Part #: 60-1001588-12)

FE 1: Type fe600,  Version 1

FE 3: Type fe600,  Version 1

Switch Fabric Module 1 Up Time is 47 minutes 7 seconds

NI-X-HSF Switch Fabric Module 2 (Serial #: BEU0335F01X,  Part #: 60-1001588-12)

FE 1: Type fe600,  Version 1

FE 3: Type fe600,  Version 1

Switch Fabric Module 2 Up Time is 47 minutes 7 seconds

==========================================================================

SL M1: NI-MLX-MR Management Module Active (Serial #: N00452F026, Part #:    35524-104A):

Boot     : Version 5.3.0T165 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Nov 16 2011 at 10:05:30 labeled as xmprm05300

     (517880 bytes) from boot flash

Monitor  : Version 5.3.0T165 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Nov 16 2011 at 10:04:52 labeled as xmb05300

     (524496 bytes) from code flash

IronWare : Version 5.3.0aT163 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Apr  6 2012 at 10:27:24 labeled as xmr05300a

     (8063716 bytes) from Primary

Board ID : 00 MBRIDGE Revision : 36

916 MHz Power PC processor 7447A (version 8003/0101) 166 MHz bus

512 KB Boot Flash (MX29LV040C), 32 MB Code Flash (MT28F128J3)

1024 MB DRAM INSTALLED

1024 MB DRAM ADDRESSABLE

Active Management uptime is 47 minutes 7 seconds

==========================================================================

SL 2: NI-MLX-10Gx2 2-port 10GbE Module (Serial #: SA05071431, Part #: 35601-200C)

Boot     : Version 5.3.0T175 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Nov 16 2011 at 10:05:54 labeled as xmlprm05300

     (509446 bytes) from boot flash

Monitor  : Version 5.3.0T175 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Nov 16 2011 at 10:05:54 labeled as xmlprm05300

     (509446 bytes) from code flash

IronWare : Version 5.3.0aT177 Copyright (c) 1996-2009 Brocade Communications Systems, Inc.

  Compiled on Apr  6 2012 at 10:33:32 labeled as xmlp05300a

     (6671380 bytes) from Primary

FPGA versions:

Valid PBIF Version = 3.27, Build Time = 10/18/2011 17:38:00

Valid XPP Version = 7.05, Build Time = 12/19/2011 19:21:00

Valid XGMAC Version = 0.15, Build Time = 10/14/2010 16:31:00

X10G2MAC 0

666 MHz MPC 8541 (version 8020/0020) 333 MHz bus

512 KB Boot Flash (AM29LV040B), 16 MB Code Flash (MT28F640J3)

512 MB DRAM, 8 KB SRAM, 286331153 Bytes BRAM

PPCR0: 768K entries CAM, 8192K PRAM, 2048K AGE RAM

LP Slot 2 uptime is 46 minutes 33 seconds

==========================================================================

All show version done

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: NI-MLX-10Gx8-D

Ok mate, the system is also running the correct code.

The error message is not enough power, please check how many PSU you have plugged in (think from memory a show chassis)

Occasional Contributor
Posts: 18
Registered: ‎03-28-2013

Re: NI-MLX-10Gx8-D

Hi Michael,

Here is the show chassis:

NetIron MLX-8 Router#show chassis

*** NetIron 8-slot Chassis ***

---POWERS ---

Power 1: ( 30351200ÿÿÿÿ 06VC1200057 - AC 1200W): Installed (OK)

Power 2: ( 30351200ÿÿÿÿ 06VC1200056 - AC 1200W): Installed (OK)

Power 3: not present

Power 4: not present

Total power budget for chassis = 2400 W

Total power used by system core = 351 W

Total power used by LPs = 150 W

Total power available = 1899 W

Slot Power-On Priority and Power Usage:

Slot2 pri=1 module type=NI-MLX-10Gx2 2-port 10GbE Module power usage=150W

--- FANS ---

right fan tray (fan 1): Status = OK, Speed = MED (75%)

right fan tray (fan 2): Status = OK, Speed = MED (75%)

right fan tray (fan 3): Status = OK, Speed = MED (75%)

right fan tray (fan 4): Status = OK, Speed = MED (75%)

--- TEMPERATURE READINGS ---

Active Mgmt Module: 34.750C 46.250C

SNM1: FE1:38.750C FE2:28.875C FE3:38.750C

SNM2: FE1:42.125C FE2:30.500C FE3:41.875C

SNM3: not present

LP2 Sensor1: 38.0C

LP2 Sensor2: 48.0C

Fans are in auto mode (current speed is MED (75%)). Temperature monitoring poll period is 60 seconds.

Thanks.

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: NI-MLX-10Gx8-D

Hi Huy1,

     Ok you have the right code on the card, correct on the system as well. You also have enough power.  This should just work as far as I can see. 

     I suggest you call the Brocade TAC for this one.

Thanks

Michael.

Occasional Contributor
Posts: 18
Registered: ‎03-28-2013

Re: NI-MLX-10Gx8-D

thanks Michael,

I've upgraded the system and module to 5.4.0 and the same problem still happened.  I've already contacted Brocade TAC and they suggested me to return the chassis.  We'll see.

Thank you everyone for all the help.

Huy.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook