Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎07-26-2011

Multiple VLANs route to ISP

I know I must be missing something simple. Booted layer 3 on a FCX 24 GS-F running 7.0.01T7f5. Multiple VLANs, 1 route to dlink router (ISP will be installed next week).

A workstation connected to one of the vlans can ping the other VE addresses. The switch can ping the workstation, the router and the internet. But I can't get the workstation to see the internet.

I've been working on this for a week and keep going round in circles. I even moved everything from a WS 648 fastiron because I couldn't assign on IP address to a port and could never get to the router or the internet. At least now I'm further than I was and now this FCX doesn't do a dhcp server. arrrrgh!!!!  My server team is making me a linux dhcp/dns, should be ready in a day or two. Not a big deal, but frustrating. Only ports 1, 3, 5, 6 need the internet. The others can, but don't have to.

Thanks in advance!

Wayne

SH Version:

telnet@RLV-MDF-FCX2#sh ver
  Copyright (c) 1996-2010 Brocade Communications Systems, Inc.
    UNIT 1: compiled on Mar 17 2010 at 22:36:07 labeled as FCXR07001b
                (4866666 bytes) from Secondary /foundry/FGS/os/FCXR07001b.bin
        SW: Version 07.0.01bT7f3
  Boot-Monitor Image size = 369286, Version:07.0.01T7f5 (grz07001)
  HW: Stackable FCX624SF
==========================================================================
UNIT 1: SL 1: FCX-24GS-F 24-port Management Module

SHOW RUN

Current configuration:
!
ver 07.0.01bT7f3
!
stack unit 1
  module 1 fcx-24-sf-port-management-module
  module 2 fcx-cx4-2-port-16g-module
!
tftp disable
global-stp
!
!
vlan 1 name DEFAULT-VLAN by port
spanning-tree
!
vlan 21 name ConvCtrController by port
tagged ethe 1/1/2
untagged ethe 1/1/3
uplink-switch ethe 1/1/2
router-interface ve 21
spanning-tree priority 1
spanning-tree rstp
!
vlan 22 name RivHotController by port
untagged ethe 1/1/24
router-interface ve 22
spanning-tree priority 1
spanning-tree rstp
!
vlan 50 name ConvCtrWIFI by port
tagged ethe 1/1/2 ethe 1/1/5
uplink-switch ethe 1/1/5
router-interface ve 50
spanning-tree priority 1
spanning-tree rstp
!
vlan 60 name RivHotWifi by port
tagged ethe 1/1/6
router-interface ve 60
spanning-tree priority 1
spanning-tree rstp
!
vlan 200 name Management by port
untagged ethe 1/1/4 ethe 1/1/23
router-interface ve 200
spanning-tree
!
!

ip dns server-address 192.168.6.1
ip route 0.0.0.0 0.0.0.0 192.168.6.1

!

!!! Do I even need or want rip?

router rip

!


interface ethernet 1/1/1
port-name ISP
ip address 192.168.6.67 255.255.255.0 dynamic
ip dhcp-client lease 23967
ip rip v2-only
!
interface ethernet 1/1/2
port-name Controller
dual-mode  21
!
interface ethernet 1/1/3
port-name AP320i
!
interface ethernet 1/1/4
port-name Mgmt
!
interface ethernet 1/1/5
port-name PBX
!
interface ethernet 1/1/6
port-name Cage
!
interface ve 21
ip address 10.21.0.1 255.255.252.0
!
interface ve 22
ip address 10.22.0.1 255.255.252.0
!
interface ve 50
ip address 10.50.0.1 255.255.248.0
!
interface ve 60
ip address 10.60.0.1 255.255.248.0
!
interface ve 200
ip address 10.2.200.12 255.255.0.0
!
!
end

telnet@RLV-MDF-FCX2#show ip route
Total number of IP routes: 6, avail: 11994 (out of max 12000)
B:BGP D:Connected  R:RIP  S:Static  O:OSPF *:Candidate default
        Destination     NetMask         Gateway         Port       Cost   Type
        0.0.0.0         0.0.0.0         192.168.6.1     1/1/1      1      S
1       10.2.0.0        255.255.0.0     0.0.0.0         v200       1      D
2       10.21.0.0       255.255.252.0   0.0.0.0         v21        1      D
3       10.50.0.0       255.255.248.0   0.0.0.0         v50        1      D
4       10.60.0.0       255.255.248.0   0.0.0.0         v60        1      D
5       192.168.6.0     255.255.255.0   0.0.0.0         1/1/1      1      D
telnet@RLV-MDF-FCX2#sh ip int
Interface           IP-Address      OK?  Method    Status             Protocol
Eth 1/1/1           192.168.6.67    YES  manual    up                 up
Ve 21               10.21.0.1       YES  NVRAM     up                 up
Ve 22               10.22.0.1       YES  NVRAM     down               up
Ve 50               10.50.0.1       YES  NVRAM     up                 up
Ve 60               10.60.0.1       YES  NVRAM     up                 up
Ve 200              10.2.200.12     YES  NVRAM     up                 up

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook