Ethernet Switches & Routers

Reply
New Contributor
Posts: 3
Registered: ‎08-31-2017
Accepted Solution

Multicast Routing in a Single Switch Environment

Greetings All,

 

I am attempting to configure multicast routing on a single-switch environment and am not having much luck.  I am running an FCX648S-HPOE, running code FCXR08030k and license FCX_ADV_ROUTER_SOFT_PACKAGE.

 

I have attempted both PIM-Dense and PIM-Sparse configs.  In short, everything seems to be fine after the configs.  I get a fully populated pim mcache table and groups.  When I show traffic however, I only see a bunch of hellos on the TX side, but no RX traffic.

 

Here is a "show ip pim mcache 224.1.1.224 (a multicast group for a streaming video test):

IP Multicast Mcache Table
Entry Flags    : SM  - Sparse Mode, SSM - Source Specific Multicast, DM - Dense Mode
                 RPT    - RPT Bit, SPT - SPT Bit, LSRC - Local Source, LRCV - Local Receiver
                 HW - HW Forwarding Enabled, FAST - Resource Allocated, TAG - Need For Replication Entry
                 REGPROB - Register In Progress, REGSUPP - Register Suppression Timer
                 MSDPADV - Advertise MSDP, NEEDRTE - Route Required for Src/RP,  PRUN - DM Prune Upstream
Interface Flags: IM - Immediate, IH - Inherited, WA - Won Assert, MCTPEERF - Traffic Forw By Cluster Peer CCEP
                 MJ - Membership Join, MI - Membership Include, ME - Membership Exclude
                 BR - Blocked RPT, BA - Blocked Assert, BF - Blocked Filter, BI - Blocked IIF
Total entries in mcache: 14

1     (*, 224.1.1.224) RP 1.1.1.1, in NIL (NIL), Uptime 00:10:23 (SM)
      No upstream neighbor because RP 1.1.1.1 is itself
      Flags (0x00260480) SM RPT LRCV
      slow ports: ethe 1/1/43
      AgeSltMsk: 0, L2 FID: 8192,  MLL: NotReq, RegPkt: 0
      Forwarding_oif: 1, Immediate_oif: 1, Blocked_oif: 0
      L3 (SW) 1:
          e1/1/43(VL236), 00:10:23/0, Flags: MJ

2     (10.235.132.130, 224.1.1.224) in v132 (e1/1/1), Uptime 00:15:16 (SM)
      Source is directly connected. RP 1.1.1.1
      Flags (0x6046c8c1) SM SPT L2REG LSRC LRCV HW FAST
      fast ports: ethe 1/1/43
      AgeSltMsk: 1, L2 FID: 4188,  MLL:    32 , RegPkt: 0
      Forwarding_oif: 1, Immediate_oif: 0, Blocked_oif: 0
      L3 (HW) 1:
          e1/1/43(VL236), 00:10:23/0, Flags: MJ
      Src-Vlan:  132

Here's an example show ip pim group

Total number of groups for VRF default-vrf: 8
1    Group 224.0.1.24
     Group member at  e1/1/45: v236
     Group member at  e1/1/43: v236
2    Group 224.0.1.60
     Group member at  e1/1/4: v235
3    Group 224.1.1.224
     Group member at  e1/1/43: v236
4    Group 239.0.0.250
     Group member at  e1/1/45: v236
5    Group 239.192.152.143
     Group member at  e1/1/45: v236
6    Group 239.255.255.250
     Group member at  e1/1/2: v237
     Group member at  e1/1/42: v237
     Group member at  e1/1/4: v235
     Group member at  e1/1/45: v237 v236
     Group member at  e1/1/1: v132
7    Group 239.255.255.253
     Group member at  e1/1/4: v235
8    Group 239.255.255.254
     Group member at  e1/1/43: v236
     Group member at  e1/1/45: v236

Here's a show ip pim traffic (from a dense config test, but the same result, no rx traffic)

Port    HELLO     JOIN-PRUNE  ASSERT    REGISTER  REGISTER  BOOTSTRAP CAND. RP  Err
                                        GRAFT(DM) STOP(SM)  MSGS(SM)  ADV.(SM)
-------+---------+-----------+---------+---------+---------+---------+---------+---
        Rx        Rx          Rx        Rx        Rx        Rx        Rx        Rx
-------+---------+-----------+---------+---------+---------+---------+---------+---
v132    0         0           0         0                                       0
v235    0         0           0         0                                       0
v236    0         0           0         0                                       0
v237    0         0           0         0                                       0
v238    0         0           0         0                                       0


Port    HELLO     JOIN-PRUNE  ASSERT    REGISTER  REGISTER  BOOTSTRAP CAND. RP  Err
                                        GRAFT(DM) STOP(SM)  MSGS(SM)  ADV.(SM)
-------+---------+-----------+---------+---------+---------+---------+---------+---
        Tx        Tx          Tx        Tx        Tx        Tx        Tx
-------+---------+-----------+---------+---------+---------+---------+---------+---
v132    9         0           0         0
v235    9         0           0         0
v236    9         0           0         0
v237    9         0           0         0
v238    8         0           0         0

 My config:

ver 08.0.30kT7f3
!
stack unit 1
  module 1 fcx-48-poe-port-management-module
  module 2 fcx-cx4-2-port-16g-module
!
global-stp
!
!
lag LAG_1 dynamic id 1
 ports ethernet 1/1/45 to 1/1/46 
 primary-port 1/1/45
 deploy
!
!
vlan 1 name DEFAULT-VLAN by port
 spanning-tree 802-1w
!
vlan 10
 tagged ethe 1/1/42 ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/39 
 spanning-tree 802-1w
!
vlan 132
 tagged ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/1 ethe 1/1/3 ethe 1/1/5 to 1/1/38 
 router-interface ve 132
 spanning-tree 802-1w
!
vlan 136
 tagged ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/47 
 router-interface ve 136
 spanning-tree 802-1w
!
vlan 235
 tagged ethe 1/1/42 ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/4 
 router-interface ve 235
 spanning-tree 802-1w
!
vlan 236
 tagged ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/43 to 1/1/44 
 router-interface ve 236
 spanning-tree 802-1w
!
vlan 237
 tagged ethe 1/1/42 ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/2 
 router-interface ve 237
 spanning-tree 802-1w
!
vlan 238
 tagged ethe 1/1/42 ethe 1/1/45 to 1/1/46 
 router-interface ve 238
 spanning-tree 802-1w
!
vlan 239
 tagged ethe 1/1/42 ethe 1/1/45 to 1/1/46 
 untagged ethe 1/1/41 
 router-interface ve 239
 spanning-tree 802-1w
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
boot sys fl sec
enable super-user-password 
enable aaa console
hostname xxxxxxxx
ip dns domain-list xxxxxxxx
ip dns server-address 10.235.236.3 10.235.236.2
ip route 0.0.0.0/0 10.235.130.2
!
mirror-port ethernet 1/1/40 input
!
username xxxxxxxx
snmp-server community xxxxxxxx
!
!
clock summer-time
clock timezone xxxxxxxx
!
!
ntp
 disable serve
 server 10.235.236.50
!
!
!
ip multicast-routing
!
router ospf
 area 0 
!
!
!
!
!
!
router pim
 bsr-candidate loopback 1 30 255
 rp-candidate loopback 1
 rp-candidate add 224.0.0.0 4
!
!
interface loopback 1
 ip address 1.1.1.1 255.255.255.255
 ip pim-sparse
 ip ospf area 0
!
interface ethernet 1/1/40
 port-name Mirror
!
interface ethernet 1/1/41
 port-name ata01
 mon ethe 1/1/40 in
!
interface ethernet 1/1/42
 port-name Wireless AP1
 inline power priority 1
!
interface ethernet 1/1/45
 port-name LAG_1
 dual-mode
!
interface ethernet 1/1/48
 port-name firewall
 ip address 10.235.130.1 255.255.255.252
!
interface ve 132
 ip address 10.235.132.1 255.255.255.0
 ip pim-sparse
 ip helper-address 1 10.235.236.3
 ip helper-address 2 10.235.236.2
 ip ospf area 0
!
interface ve 136
 ip address 10.235.136.1 255.255.255.0
 ip ospf area 0
!
interface ve 235
 ip address 10.235.235.1 255.255.255.192
 ip pim-sparse
 ip helper-address 1 10.235.236.3
 ip helper-address 2 10.235.236.2
 ip ospf area 0
!
interface ve 236
 ip address 10.235.236.1 255.255.255.0
 ip pim-sparse
 ip ospf area 0
!
interface ve 237
 ip address 10.235.237.1 255.255.255.0
 ip pim-sparse
 ip helper-address 1 10.235.236.3
 ip helper-address 2 10.235.236.2
 ip ospf area 0
!
interface ve 238
 ip address 10.235.238.1 255.255.255.0
 ip pim-sparse
 ip helper-address 1 10.235.236.3
 ip helper-address 2 10.235.236.2
 ip ospf area 0
!
interface ve 239
 ip address 10.235.239.1 255.255.255.0
 ip ospf area 0
!
!
!
!
!
lldp run
!
!
!
!
end

Any help would be greatly appreciated!!

 

Thanks!

Brocade Moderator
Posts: 73
Registered: ‎06-10-2009

Re: Multicast Routing in a Single Switch Environment

I agree that the pim mcache looks to be programmed correctly as it shows the OIFs and that they are on the shortest path tree. 

 

If this is the only PIM router (judging by the title of your post) then the lack of RX traffic is not a problem.  The RX traffic that it is counting is PIM protocol traffic.

 

Not sure what you are using to test but one problem I have come across a few times is that the IP TTL on some sources can sometimes be (unhelpfully) set to 1 which will result in the router dropping the packets.

 

Steve

 

 

New Contributor
Posts: 3
Registered: ‎08-31-2017

Re: Multicast Routing in a Single Switch Environment

Thanks for the reply Steve.  Good to hear about the RX not being an issue.  I'm using VLC to test my multicast routing.  It works perfectly on the same subnet, but to be honest I didn't even think to look at a packet capture and see if it's dying in-route.

 

I've done a quick google search, and there is an issue with VLC and TTL being set to 1, so you may have hit the nail on the head.  I'll research how to manually change the TTL in VLC, but for now I'll try testing with iperf instead and see if I've actually got everything working afterall.  I'll report back my findings.

 

Thanks!
Jeff

Brocade Moderator
Posts: 73
Registered: ‎06-10-2009

Re: Multicast Routing in a Single Switch Environment

Hello Jeff,

 

Watch out for iperf as I recall that also defaults the TTL to 1, but it is easy to change.

 

Steve

New Contributor
Posts: 3
Registered: ‎08-31-2017

Re: Multicast Routing in a Single Switch Environment

Steve, if I could buy you a beer, I would.  It was as simple as a TTL issue.  Oh, how much time have i spent spinning my wheels??!! :D

 

iperf listener:

root@ubuntu:~$ iperf -s -u -B 224.1.1.224 -i 1
------------------------------------------------------------
Server listening on UDP port 5001
Binding to local address 224.1.1.224
Joining multicast group  224.1.1.224
Receiving 1470 byte datagrams
UDP buffer size:  208 KByte (default)
------------------------------------------------------------
[  3] local 224.1.1.224 port 5001 connected with 10.235.132.130 port 59753
[ ID] Interval       Transfer     Bandwidth        Jitter   Lost/Total Datagrams
[  3]  0.0- 1.0 sec   128 KBytes  1.05 Mbits/sec   0.039 ms    0/   89 (0%)
[  3]  1.0- 2.0 sec   128 KBytes  1.05 Mbits/sec   0.061 ms    0/   89 (0%)
[  3]  2.0- 3.0 sec   128 KBytes  1.05 Mbits/sec   0.056 ms    0/   89 (0%)
[  3]  0.0- 3.0 sec   386 KBytes  1.05 Mbits/sec   0.057 ms    0/  269 (0%)

iperf source:

G:\Utilities\iperf>iperf -c 224.1.1.224 -u -T 32 -t 3 -i 1
------------------------------------------------------------
Client connecting to 224.1.1.224, UDP port 5001
Sending 1470 byte datagrams
Setting multicast TTL to 32
UDP buffer size: 64.0 KByte (default)
------------------------------------------------------------
[300] local 10.235.132.130 port 59753 connected with 224.1.1.224 port 5001
[ ID] Interval       Transfer     Bandwidth
[300]  0.0- 1.0 sec   129 KBytes  1.06 Mbits/sec
[300]  1.0- 2.0 sec   128 KBytes  1.05 Mbits/sec
[300]  2.0- 3.0 sec   128 KBytes  1.05 Mbits/sec
[300]  0.0- 3.0 sec   386 KBytes  1.05 Mbits/sec
[300] Sent 269 datagrams

Traffic when through the router perfectly. :)

 

Thanks for replying and allowing me to put this one to bed. :D

Highlighted
Brocade Moderator
Posts: 73
Registered: ‎06-10-2009

Re: Multicast Routing in a Single Switch Environment

No problem.  Glad it worked out.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook