Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 12
Registered: ‎03-26-2013

MSTP slow convergence on link-up

Hi all!

 

I have the following topology http://s29.postimg.org/no19uritj/stp_stand.png

All devices are FCX648

Configs:

sw1

 

vlan 1 name DEFAULT-VLAN by port
!
vlan 51 by port
tagged ethe 1/1/1 to 1/1/5 ethe 1/1/7 to 1/1/11
untagged ethe 1/1/6
router-interface ve 51
!
vlan 52 by port
tagged ethe 1/1/1 to 1/1/5 ethe 1/1/7 to 1/1/11
!
!
!
mstp scope all
mstp name test
mstp revision 1
mstp instance 0 vlan 1
mstp instance 0 priority 0
mstp instance 1 vlan 2 to 3500
mstp instance 1 priority 0
mstp start
!
boot sys fl sec
hostname sw1
!
!
!
!
!
!
!
!
!
!
interface ve 51
ip address 10.0.51.6 255.255.255.0
!

 sw2

vlan 1 name DEFAULT-VLAN by port
!
vlan 51 by port
 tagged ethe 1/1/1 to 1/1/4
 router-interface ve 51
!
vlan 52 by port
 tagged ethe 1/1/1 to 1/1/4
mstp scope all
mstp name test
mstp revision 1
mstp instance 0 vlan 1
mstp instance 0 ethe 1/1/2 path-cost 30000
mstp instance 1 vlan 2 to 3500
mstp instance 1 ethe 1/1/2 path-cost 30000
mstp start
!
boot sys fl sec
hostname sw2
interface ve 51
 ip address 10.0.51.24 255.255.255.0
!

 

sw3

vlan 1 name DEFAULT-VLAN by port
!
vlan 51 by port
 tagged ethe 1/1/1 to 1/1/4
 router-interface ve 51
!
vlan 52 by port
 tagged ethe 1/1/1 to 1/1/4
!
mstp scope all
mstp name test
mstp revision 1
mstp instance 0 vlan 1
mstp instance 0 ethe 1/1/2 path-cost 30000
mstp instance 1 vlan 2 to 3500
mstp instance 1 ethe 1/1/2 path-cost 30000
mstp start
!
boot sys fl sec
hostname sw3
!
!
interface ve 51
 ip address 10.0.51.22 255.255.255.0
!

 

sw4

!
vlan 1 name DEFAULT-VLAN by port
!
vlan 51 by port
 tagged ethe 1/1/1 to 1/1/4
 router-interface ve 51
!
vlan 52 by port
 tagged ethe 1/1/1 to 1/1/4
!
!
mstp scope all
mstp name test
mstp revision 1
mstp instance 0 vlan 1
mstp instance 1 vlan 2 to 3500
mstp start
!
boot sys fl sec
hostname sw4
!
!
interface ve 51
 ip address 10.0.51.25 255.255.255.0
!

 

sw5

!
vlan 1 name DEFAULT-VLAN by port
!
vlan 51 by port
 tagged ethe 1/1/1 to 1/1/4
 router-interface ve 51
!
vlan 52 by port
 tagged ethe 1/1/1 to 1/1/4
!
mstp scope all
mstp name test
mstp revision 1
mstp instance 0 vlan 1
mstp instance 1 vlan 2 to 3500
mstp start
!
boot sys fl sec
hostname sw5
!
!
!
!
!
!
!
!
!
!
interface ve 51
 ip address 10.0.51.26 255.255.255.0
!

 

Question 1:

On sw2 I see:

1/1/2  128 2    30000     F   F    ALTERNATE DISCARD 0         8000748ef8489d40

 and this is expected, since I configured cost locally.

But on sw3 I see:

1/1/2  128 2    30000     F   F    DESIGNATE FORWARD 0         8000748ef8572a00

 and this is not expected, because of configured path-cost, it must be discrding.

So the question is why so happens?

 

Question 2:

When I disable the link between sw1 and sw4 - network reconverges quickly and less than in a second, and this is expected behavior for MSTP. But when I enable the link back, sw4 places port 3 to FWD state quickly, and this is expected, but sw1 places its port 5 through discard, listen and learn states for a time about 40 seconds, like legacy 802.1d STP, and this is not expected, since all the network is running MSTP, which must have faster convergence time. I tested same topology on another vendor devices - it works fine and the network reconverges with a sub-second delay, as expected.

Why so and am I missing something?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook