Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎04-29-2017

ICX7250 and Nexus 5K - LAG dropping

I have begun experiencing problems with a 7250 stack that runs back to a Nexus 5672UP core.  I have several other stacks configured exactly the same way with no issues.  This one was running fine until a few days ago.

 

The second LAG port that runs back to the Nexus started flapping.  On the Nexus side, the link shows up; however on the Brocade side, the light for the SFP+ turns off and shows no activity; log shows the port going up and down.  Pings start timing out and traffic doesn't flow.  If I disable the link on the Nexus side or unplug the fiber from the Brocade module, everything returns to normal.

 

Current code on the Brocade tsack is 08.0.30fT211

 

Only thing I can narrow it down to right now is a possible bad SFP+

 

 

As I said, this has been working fine until 3 days ago, and runs perfectly fine on several other stacks.

 

Here is the relevant config:

 

Brocade:

========

lag ToNX01-NX02 static id 1
ports ethernet 1/2/3 ethernet 5/2/3
primary-port 1/2/3
deploy
sflow forwarding ethernet 1/2/3
sflow forwarding ethernet 5/2/3

 

interface ethernet 1/2/3
dual-mode 10

 

 

Nexus 1:

=======

interface Ethernet1/6
description {-MDF-NX01-eth1/6_po6|IDF7-STK1-10ge1/2/3-}
switchport mode trunk
switchport trunk native vlan 10
channel-group 6 mode active

 

interface port-channel6
description {-MDF-NX01-eth1/6_po6|IDF7-STK1_10ge1/2/3-}
switchport mode trunk
switchport trunk native vlan 10
vpc 6

 

Nexus 2:

=======

interface Ethernet1/6
description {-MDF-NX02-eth1/6_po6|IDF7-STK1_10ge5/2/3-}
shutdown
switchport mode trunk
switchport trunk native vlan 10
channel-group 6 mode active

 

interface port-channel6
description {-MDF-NX02-eth1/6_po6|IDF7-STK1_10ge5/2/3-}
switchport mode trunk
switchport trunk native vlan 10
vpc 6

 

Brocade Moderator
Posts: 28
Registered: ‎07-18-2016

Re: ICX7250 and Nexus 5K - LAG dropping

Hi,

 

I would tend to agree with you on the SFP. Have you tried swapping the sfp with a known working one? Does the issue symptom follow the suspected sfp? Have you tried a different port? It could be on either side, so I would try swapping each out one at a time. (ie brocade side swap - test, then cisco side swap test)

 

Sincerely

Bill

Any and all information provided by me is for entertainment value and should not be relied upon as a guaranteed solution or warranty of merchantability. All systems and all networks are different and unique. If you have a concern about data loss, or network disconnection, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, Please mark it with the button at the bottom "Accept as solution".
New Contributor
Posts: 2
Registered: ‎04-29-2017

Re: ICX7250 and Nexus 5K - LAG dropping

I have not yet tested with a known good as I am waiting on a replacement to arrive.

 

Unfortunately, I hesitate to test the suspect SFP as we are a 24/7 critical access medical facility.

 

I will try re-enabling the LAG once I have a good replacement for the Brocade SFP.  

 

Thanks!

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook