Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 6
Registered: ‎08-24-2011

How to configure round-robin channel-group load balancing

How do I configure channel-groups to support round-robin (linux bonding mode 0) load balancing?

We run a Brocade VDX 6720 and the folowing config works with linux bonding mode 4

interface TenGigabitEthernet 1/0/9
description hv4 link 1
no fabric isl enable
no fabric trunk enable
channel-group 9 mode active type standard
lacp timeout long
no shutdown
interface TenGigabitEthernet 1/0/29
description hv4 link 2
no fabric isl enable
no fabric trunk enable
channel-group 9 mode active type standard
lacp timeout long
no shutdown
interface Port-channel 9
vlag ignore-split
mtu 9216
description Downlink to Hyperviser4
switchport
switchport mode trunk
switchport trunk allowed vlan add 315-316,501,700
switchport trunk tag native-vlan
no shutdown

When the linux machines are changed to mode 0 (round-robin), communication fails.

Is there something I can configure on the VDX to support channel-group round-robin load balancing?

Thanks

Occasional Contributor
Posts: 6
Registered: ‎08-24-2011

Re: How to configure round-robin channel-group load balancing

Doing some testing...preliminary results show that changing from:

channel-group 9 mode active type standard

...to:

channel-group 9 mode on type standard

Makes a difference and the linux servers with nics configured to bonding mode 0 are now able to communicate with each other.

Frequent Contributor
Posts: 117
Registered: ‎07-26-2010

Re: How to configure round-robin channel-group load balancing

Hi Greg,

VDX config is similar to Cisco CLI config.

With Cisco port-channel

-- mode on == without any protocol e.g. LACP

-- mode active = active sending LACP

Hope this helps,

Karlheinz

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook