Ethernet Switches & Routers

Reply
ret
Contributor
Posts: 20
Registered: ‎11-16-2011

Foundry FastIron Edge X448 Premium FESX448-PREM Switch

Hello everyone!

I'm new here and new to networking, too. I have so many problems with this switch and hope the community can help me out

For this switch I have one 1GigE traffic in/out with /24 IPs on it. My problem, how can I assign one unique IP for this switch so I can access via the web-server? here is show configure command;

=============================

FESX448 Router#show config
!
Startup-config data location is flash memory
!
Startup configuration:
!
ver 04.1.00T3e3
!
!
!
!
!
!
!
!
!
enable telnet password .....
enable super-user-password .....
ip dns server-address 8.33.8.2
username ret password .....
interface ethernet 5
ip address 8.33.8.10 255.255.255.0
speed-duplex 100-full
!
!
!
!
!
!
!
!
!
end

===========================

I believed this switch have 256 IPs seen it come with /24. I try to assign 8.33.8.2 as seen above for this switch but no luck. I hope someone can help me command by command to assign this switch with IP 8.33.8.2 and help me to access this switch via web-server. I find brocade products have very limited resources and help. Thanks

Frequent Contributor
Posts: 117
Registered: ‎07-26-2010

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

Hi Ret.

It is pretty easy.

Since you are running router image (PREM = full l3) you are not able to assign a ip address to the switch itself.

You have to add a router interface to the VLAN and assign an IP address.

Since you are running all in VLAN 1 (=default) only you have to do the following:

In config mode:

- remove IP address from ether 5

- enter the following commands

  vlan 1

  router-interface ve 1

  interface ve 1

   ip address x.x.x.x/24

- you might also want to add a default gateway to the switch config with

   ip route 0.0.0.0/0 yy.yy.yy.yy

You are running a pretty old software version on this box.

You are on v4100, the latest is v7300.

Hope this helps.


Cheers

Karlheinz

ret
Contributor
Posts: 20
Registered: ‎11-16-2011

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

Hello Karlheinz,

I got error;

FESX448 Router#vlan 1
Invalid input -> vlan 1
Type ? for a list
FESX448 Router#router-interface ve 1
Invalid input -> router-interface ve 1
Type ? for a list
FESX448 Router#

perhaps I need to remove IP address from ether 5? How can I remove this IP? also, how can I clear port 5?

Thanks

Frequent Contributor
Posts: 117
Registered: ‎07-26-2010

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

You first have to change into configure mode:

  FESX448 Router# config terminal

  FESX448 Router(config)# vlan 1

and so on

ret
Contributor
Posts: 20
Registered: ‎11-16-2011

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

I have no idea about that.

FESX448 Router#config terminal
FESX448 Router(config)#vlan 1
FESX448 Router(config-vlan-1)#router-interface ve 1
error - IP routing, ip policy or route-only was configured on ports  5
FESX448 Router(config-vlan-1)#
can you give me command to remove IP on port 5? also command to clear config on 5? Thanks
Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

A bit closer...
FESX448 Router(config)#interface ethernet 5
FESX448 Router(config)#no ip address 8.33.8.10 255.255.255.0
Thanks
Michael.
Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

Hi,

     You woudl also want to add these two lnes so you can use the username you create to login to the web interface.

FESX448 Router(config)#aaa authentication web-server default local

FESX448 Router(config)#aaa authentication login default local

Thanks

Michael.

ret
Contributor
Posts: 20
Registered: ‎11-16-2011

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

Wow. many thanks on both of you.

FESX448 Router(config-vif-1)#show config
!
Startup-config data location is flash memory
!
Startup configuration:
!
ver 04.1.00T3e3
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
enable telnet password .....
enable super-user-password .....
ip dns server-address 8.33.8.2
username ret password .....
web-management tcp-port 4321
web-management https
interface ethernet 5
speed-duplex 100-full
!
interface ve 1
ip address 8.33.8.2 255.255.255.0
!
!
!
!
!
!
!
!
!
end

====================

It still nothing when I go to https://8.33.8.2:4321

is everything show corrected?

Frequent Contributor
Posts: 117
Registered: ‎07-26-2010

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

You have to generate a certificate for https!

conf terminal

crypto-ssl certificate generate

for SSH do:

crypto key generate

Cheers

Karlheinz

ret
Contributor
Posts: 20
Registered: ‎11-16-2011

Re: Foundry FastIron Edge X448 Premium FESX448-PREM Switch

I reboot the switch before

conf terminal

crypto-ssl certificate generate

or

for SSH do:

crypto key generate

now;

FESX448 Router>enable
Password:
Error - incorrect password.
FESX448 Router>

I do not know why my old/current password not work. I will have to go to the data center to reset this password, I guess. Cheers!

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook