Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 6
Registered: ‎08-27-2011

Establishing a trunk between FCX and Cisco 3560 switches


I'm attempting to establish a trunk between a Brocade FCX648-E and a Cisco 3560-X IP switches.  I have some working knowledge of both makes of switches.  I recently established lacp base trunking between FCX648 and VDX switches. So my next step is to make it work across different switch makes.  Below are snippets of Cisco and Brocade configs and some "show" outputs.  I've been able to establish a trunk using a single connection, via "link-aggregate configure singleton" on the FCX.

My attempt to configure multiple links in a trunk has halted, as I am unable to get both the Cisco and FCX Admin keys to be the same value. On the FCX: "User configured key must be between 10000 and 65535." On the Cisco, I have yet to find a similar option. My output shows a Cisco Admin key of "0x2"  Obviously that is not within the same range as what the FCX allows. Before I venture more into it, I'm hoping someone has some insight/experience or even working examples to establish a multi-link trunk between an FCX and Cisco Catalyst Switch.

Thanks,

Ben

Here are my initial config settings:

Cisco 3560-X

...

interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk

...

interface GigabitEthernet1/1
switchport trunk encapsulation isl
switchport mode trunk
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active

!

--------------------------------------

show etherchannel detail
        Channel-group listing:
        ----------------------

Group: 2
----------
Group state = L2
Ports: 1   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0
        Ports in the group:
        -------------------
Port: Gi1/2
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 2           Mode = Active          Gcchange = -
Port-channel  = Po2         GC   =   -             Pseudo port-channel = Po2
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/2     SA      bndl      32768         0x2       0x2     0x133       0x3D 

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi1/2     FA      1         748e.f868.c5c0  18s    0x0    0x2711 0x1     0x3F 

Age of the port in the current state: 0d:00h:22m:51s

        Port-channels in the group:
        ---------------------------

Port-channel: Po2    (Primary Aggregator)
         

------------

Age of the Port-channel   = 0d:01h:35m:44s
Logical slot/port   = 2/2          Number of ports = 1
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/2    Active             0

Time since last port bundled:    0d:00h:22m:52s    Gi1/2
Time since last port Un-bundled: 0d:00h:23m:03s    Gi1/2

--------------------------------------


FCX648-E

interface ethernet 1/1/1
link-aggregate configure singleton
link-aggregate active
!

!
vlan 10 by port
tagged ethe 1/1/1
untagged ethe 1/1/48
!
vlan 15 by port
tagged ethe 1/1/1
untagged ethe 1/1/47
!

---------------------------------------

telnet@FCX648 Router#show link-aggregate
System ID:
Long  timeout: 120, default: 120
Short timeout: 3, default: 3
Port 
1/1/1       1        1 singleton   Yes   S   Agg  Syn  Col  Dis  No   No   Ope

---------------------------------------

New Contributor
Posts: 4
Registered: ‎06-19-2013

Re: Establishing a trunk between FCX and Cisco 3560 switches

I have very limited experience with Brocade and none with FCX-series at all, but here's my two EURO-cents.

First, you do not have to set the key in Cisco devices. That comes automatically, as I have understood it. Secondly, you cannot use ISL, that is Cisco proprietary protocol. You have to use 802.1Q as encapsulation protocol.

switchport trunk encapsulation dot1q

switchport mode trunk

On some devices and IOS versions the commands must be entered in this order. If your device won't support dot1q but only isl you can't use that device for trunking.

Also, on Brocade you have to use individual keys for each trunk set. That is, eg 10000 for ports 1-4 towards device 1, 10001 for ports 5-6 towards device 2 and so forth.

Remove the singleton -command from ports. That is meant for single-port trunk. Don't know what good is that for, though.

Here's a sample from a working trunk, both ports are part of the same trunk. Different trunk would have different key.

interface ethernet 1/1/23

link-aggregate configure key 10001

link-aggregate active

!

interface ethernet 2/1/23

link-aggregate configure key 10001

link-aggregate active


Hope this helps.

Edit: just noticed how old this message was. Hopefully you have had success with your attempt. I do feel silly now.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook