Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 14
Registered: ‎02-18-2011

Dhcp problem with ip phones

I have 5 FWS 648G PoE with two vlans on them : Data vlan is 101 and Voice vlan is 909. The firmware and the configs of the switchs haven't change since april. Since yesterday, if i unplug an ip phone and replug it, the phone will receive the dhcp from the dhcp server in the data vlan! All others phones are working well until I unplug them.

data vlan and voice vlan have each a separate dhcp server.

If I remote dual-mode from the port, the phone get the dhcp from the voice vlan, but as soom as I put back dual-mode, the ip phone receive the dhcp from the data vlan.

Here is a summary of the configuration of one switch, version is 07202a :

ver 07.2.02aT7e1
!
module 1 fws1g-48-port-copper-base-module
!
!
!
!
vlan 1 by port
tagged ethe 0/1/1 ethe 0/1/20 ethe 0/1/48
spanning-tree 802-1w
spanning-tree 802-1w priority 400
!
vlan 101 by port
tagged ethe 0/1/1 to 0/1/44 ethe 0/1/46 ethe 0/1/48
spanning-tree 802-1w
spanning-tree 802-1w priority 400
!
vlan 301 by port
tagged ethe 0/1/1 ethe 0/1/48
spanning-tree 802-1w
spanning-tree 802-1w priority 400

vlan 909 by port
tagged ethe 0/1/1 to 0/1/44 ethe 0/1/46 ethe 0/1/48
spanning-tree 802-1w
spanning-tree 802-1w priority 400
!
vlan 913 by port
tagged ethe 0/1/1 ethe 0/1/48
untagged ethe 0/1/45
spanning-tree 802-1w
spanning-tree 802-1w priority 400
!
vlan 914 by port
tagged ethe 0/1/1 ethe 0/1/48
untagged ethe 0/1/47
spanning-tree 802-1w
spanning-tree 802-1w priority 400
!
vlan 4050 name DEFAULT-VLAN by port
no spanning-tree
!
!
!

!
!
!
!
qos mechanism strict
aaa authentication snmp-server default local
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
default-vlan-id 4050
hostname CTT1-SW2
ip address 10.250.0.82 255.255.0.0
no ip dhcp-client auto-update enable
no ip dhcp-client enable
ip multicast passive
ip default-gateway 10.250.0.1
telnet access-group 10
username admin password .....
cdp run
fdp run
snmp-server community ..... ro
snmp-server community ..... rw
snmp-server host 10.250.0.2 version v1 .....


interface ethernet 0/1/1
port-name CTT2-SW2
spanning-tree 802-1w admin-pt2pt-mac
!
interface ethernet 0/1/2
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/3
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/4
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/5
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/6
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/7
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/8
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/9
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/10
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/11
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/12
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/13
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/14
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/15
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/16
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/17
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/18
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/19
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/21
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/22
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/23
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/24
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/25
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/26
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/27
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/28
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/29
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/30
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/31
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/32
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/33
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/34
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/35
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/36
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/37
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/38
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/39
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/40
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/41
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/42
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/43
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/44
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/46
dual-mode  101
inline power
voice-vlan 909
!
interface ethernet 0/1/48
port-name CTT1-SW1
spanning-tree 802-1w admin-pt2pt-mac
!
!
access-list 10 permit 10.1.3.0 0.0.0.255
access-list 10 remark Pour ironview
access-list 10 permit host 10.1.1.93
!
!
lldp tagged-packets process
lldp med network-policy application voice tagged vlan 909 priority 6 dscp 48 ports ethe 0/1/1 to 0/1/48
lldp advertise vlan-name vlan 909 ports ethe 0/1/1 to 0/1/48
lldp run
!
!
!
!
end

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook