Ethernet Switches & Routers

Reply
New Member
Posts: 1
Registered: ‎11-20-2015

DHCP requests not working for Windows clients attached to an ICX 6430 switch

Hello,

 

I'm a Brocade newbie so sorry for this stupid case ;-)

 

I have an ICX 6430 configured with ethe 1/1/1 as the uplink port to a Cisco Catalyst swith and ethe 1/1/2 to 1/1/24 connect DHCP-enabled Windows computers through VLAN 24. DHCP leases are handled by Windows servers where Catalyst switches act as IP helpers. VLAN 1 is for management through ethe 1/1/1.

 

Windows clients work fine when non-DHCP; however they do not receive leases when DHCP-enabled, so I do not suspect Cisco as the culprit ;-(

 

Cisco Catalyst uplink port config:

 

interface GigabitEthernet1/0/9
switchport trunk allowed vlan 1,21-24,28,504,900,998,999
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
spanning-tree guard root

 

Brocade ICX 6430 shows the following configuration:

 

Current configuration:
!
ver 07.4.00bT311
!
stack unit 1
module 1 icx6430-24-port-management-module
module 2 icx6430-sfp-4port-4g-module
!
vlan 1 by port
tagged ethe 1/1/1
management-vlan
default-gateway 10.1.2.5 1
!
vlan 24 name SS-POSTES-ADM by port
tagged ethe 1/1/1 to 1/1/24
!
vlan 4095 name DEFAULT-VLAN by port
!
aaa authentication web-server default local
aaa authentication login default local
default-vlan-id 4095
enable telnet password .....
hostname CSP-Test-CENTRE-ADMIN
ip address 10.1.2.38 255.255.0.0
logging host 10.2.1.77
username admin password .....
cdp run
fdp run

web-management https
interface ethernet 1/1/1
port-name *** Uplink ***
dual-mode 1
!
end

 

Thanks in advance for your help !

Occasional Contributor
Posts: 7
Registered: ‎01-07-2010

Re: DHCP requests not working for Windows clients attached to an ICX 6430 switch

Untag vlan24 on all ports except for the uplink to the Cisco switch.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Download FREE NVMe eBook