Ethernet Fabric (VDX, CNA)

Reply
Frequent Visitor
Posts: 1
Registered: ‎06-22-2016

check fcoe login from linux host

Hi Guys,

 

I am very new to Storage and Networking world.

 

I am trying to set up open FCoe in redhat linux and I have 10 GB CNA card on host and connected to Brocade 8000 switch slot 0/22

 

But i am unable to login/discover fcoe connections from/to switch.

 

So Now i need to be setup fcoe port for 0/22 and it should accept fcoe traffic from cna adapter from host

 

below are the details that may help to correct me.

sw246#show interface tengigabitethernet 0/22
TenGigabitEthernet 0/22 is up, line protocol is up (connected)
Hardware is Ethernet, address is 0005.1e76.6a3a
    Current address is 0005.1e76.6a3a
Pluggable media present, Media type is sfp
    Wavelength is 850 nm
Interface index (ifindex) is 404095494
MTU 2500 bytes
LineSpeed: 10000 Mbit, Duplex: Full
Flowcontrol rx: on, tx: on
Last clearing of show interface counters: 08:10:44
Queueing strategy: fifo
Receive Statistics:
    425 packets, 27835 bytes
    Unicasts: 0, Multicasts: 425, Broadcasts: 0
    64-byte pkts: 337, Over 64-byte pkts: 88, Over 127-byte pkts: 0
    Over 255-byte pkts: 0, Over 511-byte pkts: 0, Over 1023-byte pkts: 0
    Over 1518-byte pkts(Jumbo): 0
    Runts: 0, Jabbers: 0, CRC: 0, Overruns: 0
    Errors: 0, Discards: 0
Transmit Statistics:
    7 packets, 1047 bytes
    Unicasts: 0, Multicasts: 7, Broadcasts: 0
    Underruns: 0
    Errors: 0, Discards: 0
Rate info (interval 299 seconds):
    Input 0.000720 Mbits/sec, 1 packets/sec, 0.00% of line-rate
    Output 0.000304 Mbits/sec, 0 packets/sec, 0.00% of line-rate
Time since last interface status change: 00:01:12

 

sw246#show vlan brief

VLAN     Name            State   Ports                          
                                 (u)-Untagged, (t)-Tagged
                                 (c)-Converged
======= ================ ======= ===============================
1       default          ACTIVE  Te 0/0(u) Te 0/2(u) Te 0/3(u)
                                 Te 0/4(u) Te 0/5(u) Te 0/6(u)
                                 Te 0/7(u) Te 0/9(u) Te 0/10(u)
                                 Te 0/11(u) Te 0/12(c) Te 0/13(c)
                                 Te 0/14(c) Te 0/15(u) Te 0/16(u)
                                 Te 0/17(c) Te 0/18(u) Te 0/19(u)
                                 Te 0/20(u) Te 0/21(u) Te 0/23(c)
                                 Po 2(t)
2       VLAN0002         ACTIVE  
3       VLAN0003         ACTIVE  
5       VLAN0005         ACTIVE  
10      VLAN0010         ACTIVE  
11      VLAN0011         ACTIVE  Te 0/1(c) Te 0/12(c) Te 0/14(c)
                                 Te 0/22(c)

 

sw246#show lldp interface tengigabitethernet 0/22
LLDP information for Te 0/22
  State:                   Enabled
  Mode:                    Receive/Transmit
  Advertise Transmitted:   30 seconds
  Hold time for advertise: 120 seconds
  Re-init Delay Timer:     2 seconds
  Tx Delay Timer:          1 seconds
  DCBX Version :           pre-CEE
  Auto-Sense :             Yes
  Transmit TLVs:           Chassis ID               Port ID                  
                           TTL                      Port Description         
                           System Name              System Description       
                           System Capabilities      IEEE DCBx                
                           DCBx FCoE App            DCBx FCoE Logical Link   
                           Link Prim                Brocade Link             DCBx iSCSI App           
  DCBx FCoE Priority Bits: 0x8
  DCBx iSCSI Priority Bits: 0x5

 

sw246:admin> fcoe --cfgshow 22
Port: 22, Status: Enabled, Port WWN: 20:16:00:05:1e:76:6a:00, DeviceCount: 0, Type: VF-Port, MAC: 00:05:1e:76:6a:0e
VF_ID: 128, Fabric Name: 10:00:00:05:1e:76:6a:00

 

In linux host I am getting below error

 

[root@dhamu ~]# fcoeadm -i
No FCoE interfaces created.

 

I tried below steps

 

cp /etc/fcoe/cfg-eth0  /etc/fcoe/cfg-eth2
# /etc/init.d/lldpad start

 

# dcbtool sc eth2 dcb on
# dcbtool sc ethX app:fcoe e:1
# ifconfig ethX up
# service fcoe start

[root@dhamu ~]# fcoeadm -i
No FCoE interfaces created.

 

[root@dhamu ~]# cat /sys/class/fc_host/host*/port_state
Linkdown
Linkdown

 

[root@dhamu ~]# ethtool eth2
Settings for eth2:
    Supported ports: [ FIBRE ]
    Supported link modes:   10000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: No
    Advertised link modes:  10000baseT/Full
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: No
    Speed: 10000Mb/s
    Duplex: Full
    Port: Other
    PHYAD: 0
    Transceiver: external
    Auto-negotiation: off
    Supports Wake-on: d
    Wake-on: d
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

 

Please help to configure fcoe interface and let me know switch configuration is correct for my requirement

 

 

 

 

 

 

 

Frequent Contributor
Posts: 95
Registered: ‎03-23-2015

Re: check fcoe login from linux host

Hi @asteroid4u,

 

While we still encourage the community to assist with your post, I wanted to let you I have passed your questions on to our TAC Engagement team and they will be reaching out to you shortly to gather some more information regarding your configuration so we can get you in touch with the correct group . I encourage you to continue to post in the community and let me know if there is any way I can help. Once your post is resolved, we will make sure to post the resolution back to the community to help other members.


You can find out more about the TAC Engaged program by clicking on the image below.

 

TAC Engaged.png

 

 

 

Dennis Smith
Manager Brocade Communities
@DennisMSmith

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook