Ethernet Fabric (VDX, CNA)

Reply
Visitor
Posts: 1
Registered: ‎10-18-2014

bgp / pim / rp-address

Hi All,

 

Need to implement BGP routing with my VDX 6740 box running 5.01 release

 

Requirement / current status

 

1.) BGP peer is established succesfully with both primary and secondary path

2.) TCP traffic is happening without any problem - tested with failover conditions

 

3.) In the configuration two nos of rp-address are configured to recive multicast streams. Each rp-address has got its own multicast sources like given below

 

for rp-address 172.19.1.101
239.50.51.121/32
239.50.51.122/32

for rp-address 172.19.1.201
239.70.71.43/32
239.70.71.44/32

 

the challenge we face here to map this multicast groups to respective respective address.

 

Would like to have this community support to implement this required feature. I am unable to find the documents in this regard

 

Also, note that the same has been successfully implemented with Dell Force10 in the same location to validate the configuration provided by the Service Vendor.

 

current Config files of both Brocade VDX 6740 and Dell Force10 are given below

 

Please note the last few lines  given under Dell Force10 switch. Similary Brocade VDX 6740 needs to be configured

 

Brocade VDX 6740

 

router pim
rp-address 172.19.1.101
rp-address 172.19.1.201
!
router bgp
local-as 65232
neighbor 10.30.2.177 remote-as 65500
neighbor 10.30.2.177 description EBGP-NSE-Uplink-1
neighbor 10.30.2.177 password 2 $dDRuQlEjUQ==
neighbor 10.31.2.177 remote-as 65500
neighbor 10.31.2.177 description EBGP-NSE-Uplink-2
neighbor 10.31.2.177 password 2 $dDRuQlEjUQ==
address-family ipv4 unicast
network 10.230.78.0/25
!
!
interface Ve 935
ip proxy-arp
ip address 10.230.78.1/25
ip pim-sparse
no shutdown

interface TenGigabitEthernet 1/0/1
no fabric isl enable
no fabric trunk enable
switchport
switchport mode access
switchport access vlan 935
spanning-tree shutdown
shutdown

interface TenGigabitEthernet 1/0/23
no fabric isl enable
no fabric trunk enable
ip proxy-arp
ip address 10.30.2.178/30
ip pim-sparse
no shutdown
!
interface TenGigabitEthernet 1/0/24
no fabric isl enable
no fabric trunk enable
ip proxy-arp
ip address 10.31.2.178/30
ip pim-sparse
no shutdown
!

 

Dell Force10

 

 

interface TenGigabitEthernet 0/0
ip address 10.30.1.26/30
mtu 9600
flowcontrol rx on tx off
ip pim sparse-mode
no shutdown
!
interface TenGigabitEthernet 0/1
ip address 10.31.1.26/30
mtu 9600
flowcontrol rx on tx off
no negotiation auto
ip pim sparse-mode
no shutdown
!

 

interface TenGigabitEthernet 0/2
no ip address
mtu 9600
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
no shutdown

 


interface Vlan 879
no ip address
shutdown
!
router bgp 65169
network 10.230.46.0/25
neighbor 10.30.1.25 remote-as 65500
neighbor 10.30.1.25 password 7 5b79a548540ec358f3467f26e80b1d25
neighbor 10.30.1.25 no shutdown
neighbor 10.31.1.25 remote-as 65500
neighbor 10.31.1.25 password 7 5b79a548540ec358f3467f26e80b1d25
neighbor 10.31.1.25 no shutdown

 

ip pim rp-address 172.19.1.201 group-address 239.70.71.41/32
ip pim rp-address 172.19.1.201 group-address 239.70.71.42/32
ip pim rp-address 172.19.1.201 group-address 239.70.71.43/32
ip pim rp-address 172.19.1.201 group-address 239.70.71.44/32
ip pim rp-address 172.19.1.101 group-address 239.70.71.111/32
ip pim rp-address 172.19.1.101 group-address 239.70.71.121/32
ip pim rp-address 172.19.1.101 group-address 239.70.71.122/32

 

 

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook