Ethernet Fabric (VDX, CNA)

Reply
New Contributor
Posts: 3
Registered: ‎11-25-2015
Accepted Solution

VLAN NOS command help

Apologies in advanced for the basic nature of my questions, I have just inherited half a dozen ICX and VDX live switches so its day 1 in Brocade for me! am having a play with NOS on a VDX6740 to understand the command structure.

Created a test VLAN > added description > selected an unused port and made it an access port within the VLAN

(config) # interface vlan 1000
(config)# interface TenGigabitEthernet 5/0/30
(conf-if-te-5/0/30)# switchport
(conf-if-te-5/0/30)# switchport mode access
(conf-if-te-5/0/30)# exit
(conf-if-te-5/0/30)# switchport access allowed vlan 1000

I later deleted the test VLAN

(config)# no interface vlan 1000

But when I do a show interface status the port is still marked as access

Te 5/0/30    sfpAbsent     Access     --       --

I want to return it to this below

Te 5/0/30    sfpAbsent     --         --       --

But I cant seem to find how to do that would anyone be kind enough to point me in the right direction

 

Kind regards

 

Dev

Contributor
Posts: 23
Registered: ‎06-16-2015

Re: VLAN NOS command help

[ Edited ]

no switchport

Jacob Bartlett
http://bartlett.network
https://www.linkedin.com/in/jacobbartlett
New Contributor
Posts: 3
Registered: ‎11-25-2015

Re: VLAN NOS command help

Jacob,

 

Many thanks, sadly no joy

 

(config)# interface TenGigabitEthernet 5/0/30
(conf-if-te-5/0/30)# no switchport mode access
----------------------------------------------^
syntax error: unknown element

Having played around am still having problems


(conf-if-te-5/0/30)# switchport
Possible completions:
  access          Set the Layer2 interface as Access
  mode            Set mode of the Layer2 interface
  port-security   Enable port-security feature
  private-vlan    Set Private-Vlan Configuration
  trunk           Set the Layer2 interface as trunk
  <cr>
(conf-if-te-5/0/30)# switchport mode
Possible completions:
  access                    Set the Layer2 interface as Access
  private-vlan              Set the Layer2 interface as private-vlan
  trunk                     Set the Layer2 interface as trunk
  trunk-no-default-native   Set the Layer2 interface as trunk-no-default-native
(conf-if-te-5/0/30)# switchport mode trunk-no-default-native
%%Error: Cannot use switchport-trunk-no-default-native mode when virtual-fabric is disabled.

 

I cant afford to play around with virtual-fabric if indeed this is the correct way to go

 

Brocadian
Posts: 9
Registered: ‎01-18-2012

Re: VLAN NOS command help

Hi Dev,

 

"no switchport" works for me i.e. leave off the "access"

 

Steve

New Contributor
Posts: 3
Registered: ‎11-25-2015

Re: VLAN NOS command help

DOH!

 

Bingo! many thanks Steve :)

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook