Ethernet Fabric (VDX, CNA)

Reply
New Contributor
Posts: 2
Registered: ‎07-15-2014

VDX port channel Cisco

I have a connection problem with two VDX 6710 connect to two Cisco 6506 via a portchannel.  The connection is as such Cisco Core A --> VDX A   Cisco Core B --> VDX B.  In regards to spanning-tree the Cisco Core A is the root switch.  Also, the Cisco are the layer 3 of the vlans and their portchannels are configured as such

 

switchport mode trunk 

switchport trunk encapsulation dot1q  

 

On the VDXs the interfaces of the portchannel are set as such

 

 fabric isl enable
 fabric trunk enable
 channel-group 25 mode active type standard
 lacp timeout long

 

The VDX portchannel itself is configured as such

 

 vlag ignore-split
 switchport
 switchport mode trunk
 no switchport trunk tag native-vlan

 

The issue I have is that accessing the hosts behind the VDX is intermittent.  For instance, I can access a host from 1000-1020 but not from 1021-1041.  I havent identified a pattern in them being reachable and not reachable.  Any ideas on what may be causing this behavior?

Contributor
Posts: 48
Registered: ‎02-27-2012

Re: VDX port channel Cisco

[ Edited ]

We have Cisco Access-Switches behind VDX Fabrics because of the missing 100B-T or 10B-T Ports. Both have LACP configured so STP is not needed - but STP should be transparent to the fabric (fabric acts like one transparent switch). 

 

Our cisco config is like:

 

interface port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
spanning-tree bpdufilter enable
end

 

interface GigabitEthernet0/47
switchport trunk encapsulation dot1q
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
channel-group 1 mode active
spanning-tree bpdufilter enable
end

 

 

and VDX like

 

Accessport
interface GigabitEthernet  xx/0/48
channel-group 1234 mode active type standard
lacp timeout long
sflow enable
no shutdown

 

interface Port-channel 1234
vlag ignore-split
speed 1000
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
qos flowcontrol tx on rx on
spanning-tree shutdown
no shutdown

 

and it is working fine.

 

i hope this helps...

 

cheers Dennis

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.