Ethernet Fabric (VDX, CNA)

Reply
Occasional Contributor
Posts: 9
Registered: ‎10-26-2011

VDX and Private VLAN trunks

I have an issue with trunking of private VLANs on my 6740 environment.  I have a few private VLANs configured like the following example:-

 

interface Vlan 964
description VirtPriv220Isolated
private-vlan isolated
!

interface Vlan 965
description VirtPriv220Primary
private-vlan primary
private-vlan association add 964
!

 

and I have a port channel configured for connectivity to our central switch stack:-

 

interface Port-channel 1
vlag ignore-split
speed 1000
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk allowed vlan remove 2
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
!

 

However, if I view the status of these VLANs, they are not bound to any ports:-

 

RB01# show vlan 964
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
964 VLAN0964 INACTIVE(no member port)

 

RB01# show vlan 965
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
965 VLAN0965 INACTIVE(no member port)

 

On a different VDX fabric, I have essentially the same configuration but I see the following:-

 

RB1# show vlan 964
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged, (t)-Tagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT
================ =============== ========================== ============================= ===========================
964 VLAN0964 ACTIVE Po 1(t)

RB1# show vlan 965
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged, (t)-Tagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT
================ =============== ========================== ============================= ===========================
965 VLAN0965 ACTIVE Po 1(t)

 

The port channel configuration on this fabric looks like this:-

 

RB1# show run int po 1
interface Port-channel 1
vlag ignore-split
speed 1000
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
!

 

Which is exactly the same.  The only difference between the two fabrics is that the one the works is running 4.1.0a software but the one that doesn't is running 5.0.1a.

 

 

Any VLAN that isn't part of a private VLAN configuration is trunked over this port-channel with no problems:-

 

RB01# show vlan 456
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
456 VLAN0456 ACTIVE Po 1(t)

 

I'm lost...

New Contributor
Posts: 2
Registered: ‎03-12-2015

Re: VDX and Private VLAN trunks

Hello Mark,

 

I think i got the same problem while starting with version 5.

The support told us to configure in case of

 

"switchport mode trunk"

 

to use

 

"switchport mode private-vlan trunk"

 

which supports transport of normal vlans too, when "switchport trunk allowed vlan all|99" is set.

 

 

For each used secondary vlan on this port you have to use "switchport private-vlan association trunk 9 99" to allow it.

When you are trying to configure it i think you will understand what i mean.

The configuration blows up.

 

Regards

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook