Ethernet Fabric (VDX, CNA)

Reply
New Contributor
Posts: 2
Registered: ‎03-31-2011

VDX VCS to SX1600 Issue

Hi all,

I'm hoping someone might be able to shed a little light on an issue I'm facing.

I have 2 x VDX6720 connected together to make VCS Cluster. On each of these I have 2 connections to a FastIron Sx1600. Please see the attached diagram. Basically SX1 has a 10Gb connection to each of the VDX's creating a VLAG as does SX2. There are also 2 VM Hosts running a couple of servers on each patched into each VDX again creating the VLAG. Communications between servers connected into the VDX's are fine. The problem is from some devices on the SX's.

Any device on SX1 can communicate with the VM Hosts with no issue. If you're on a device in SX2 then you can sometime communicate with the VMHosts on the VDX's and sometimes not. Not all devices on SX2 communicate at the same time. Not that VRRP-E is used between the 2 SX's for redundancy. SX1 is in general the Master/Owner.

Below is some of the relevant configuration parts

Many thanks in advance,

Kevin

Note SX's are running L3 7.4 and VDX are running NOS 2.1.1,

SX1


module 17 fi-sx6-2-port-10gig-fiber-module

trunk ethe 9/1 to 9/2

!

VLAN120

tag e9/1 to 9/2

tag e17/1 to 17/2

untag e2/1

spanning-tree priority 500

!

VLAN132

tag e9/1 to 9/2

tag e17/1 to 17/2

spanning-tree priority 500

!

router vrrp-extended

!

interface ethernet 9/1

pvst-mode

!

interface ethernet 17/1

link-aggregate configure key 10010

link-aggregate active

pvst-mode

!

interface ethernet 17/2

link-aggregate configure key 10010

link-aggregate active

pvst-mode

!

interface ve 120

ip address 10.10.20.2 255.255.255.0

ip vrrp-extended vrid 120

  backup priority 120 track-priority 20

  ip-address 10.10.20.1

  track-port e 9/1

  enable

interface ve 132

ip address 10.10.32.2 255.255.255.0

ip vrrp-extended vrid 132

  backup priority 120 track-priority 20

  ip-address 10.10.32.1

  track-port e 9/1

  enable

!

sh link-agg

System ID: 0012.f2cf.1818

Long  timeout: 120, default: 120

Short timeout: 3, default: 3

Port 

17/1       1        1    10010   Yes   L   Agg  Syn  Col  Dis  No   No   Ope

17/2       1        1    10010   Yes   L   Agg  Syn  Col  Dis  No   No   Ope

SX2


module 17 fi-sx6-2-port-10gig-fiber-module

trunk ethe 9/1 to 9/2

!

VLAN 120

untag e2

tag e9/1 to 9/2

tag e17/1 to 17/2

untag e2/1

spanning-tree priority 500

!

VLAN 132

tag e9/1 to 9/2

tag e17/1 to 17/2

spanning-tree priority 500

!

interface ethernet 9/1

pvst-mode

!

interface ethernet 17/1

link-aggregate configure key 10011

link-aggregate active

pvst-mode

!

interface ethernet 17/2

link-aggregate configure key 10011

link-aggregate active

pvst-mode

!

interface ve 120

ip address 10.10.20.3 255.255.255.0

ip vrrp-extended vrid 120

  backup priority 110 track-priority 20

  ip-address 10.10.20.1

  track-port e 9/1

  advertise backup

  enable

interface ve 132

ip address 10.10.32.3 255.255.255.0

ip vrrp-extended vrid 132

  backup priority 110 track-priority 20

  ip-address 10.10.32.1

  track-port e 9/1

  advertise backup

  enable

!

sh link-aggregate

System ID: 748e.f83e.2400

Long  timeout: 120, default: 120

Short timeout: 3, default: 3

Port 

17/1       1        1    10011   Yes   L   Agg  Syn  Col  Dis  No   No   Ope

17/2       1        1    10011   Yes   L   Agg  Syn  Col  Dis  No   No   Ope


VDX1

rbridge-id 1

fabric ecmp load-balance dst-mac-vid

!

!

interface Vlan 120

  no shutdown

!

interface Vlan 132

  no shutdown

!

interface TenGigabitEthernet 1/0/1

no fabric isl enable

no fabric trunk enable

channel-group 1 mode on type standard

no shutdown

!

interface TenGigabitEthernet 1/0/2

no fabric isl enable

no fabric trunk enable

channel-group 2 mode on type standard

no shutdown

!

interface TenGigabitEthernet 1/0/9

no fabric isl enable

no fabric trunk enable

channel-group 9 mode active type standard

lacp timeout long

no shutdown

!

interface TenGigabitEthernet 1/0/10

no fabric isl enable

no fabric trunk enable

channel-group 10 mode active type standard

lacp timeout long

no shutdown

!

interface TenGigabitEthernet 1/0/11

fabric isl enable

fabric trunk enable

no shutdown

!

interface TenGigabitEthernet 1/0/12

fabric isl enable

fabric trunk enable

no shutdown

!

interface Port-channel 1

vlag ignore-split

description 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 2

vlag ignore-split

description 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 9

vlag ignore-split

description 9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 10

vlag ignore-split

description 10

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

Static Aggregator: Po 1 (vLAG)

Aggregator type: Standard

Member rbridges:

   rbridge-id: 1 (1)

   rbridge-id: 2 (1)

Member ports on rbridge-id 1

  Te 1/0/1   *

Static Aggregator: Po 2 (vLAG)

Aggregator type: Standard

Member rbridges:

   rbridge-id: 1 (1)

   rbridge-id: 2 (1)

Member ports on rbridge-id 1

  Te 1/0/2   *

!

LACP Aggregator: Po 9 (vLAG)

Aggregator type: Standard

Ignore-split is enabled

Member rbridges:

   rbridge-id: 1 (1)

   rbridge-id: 2 (1)

Actor System ID - 0x8000,01-e0-52-00-00-01

Admin Key: 0009 - Oper Key 0009

Receive link count: 1 - Transmit link count: 1

Individual: 0 - Ready: 1

Partner System ID - 0x0001,00-12-f2-cf-18-18

Partner Oper Key 10010

Member ports on rbridge-id 1:

  Link: Te 1/0/9 (0x118090008) sync: 1   *

!

LACP Aggregator: Po 10 (vLAG)

Aggregator type: Standard

Ignore-split is enabled

Member rbridges:

   rbridge-id: 1 (1)

   rbridge-id: 2 (1)

Actor System ID - 0x8000,01-e0-52-00-00-01

Admin Key: 0010 - Oper Key 0010

Receive link count: 1 - Transmit link count: 1

Individual: 0 - Ready: 1

Partner System ID - 0x0001,74-8e-f8-3e-24-00

Partner Oper Key 10011

Member ports on rbridge-id 1:

  Link: Te 1/0/10 (0x1180A0009) sync: 1   *

VDX2


rbridge-id 2

fabric ecmp load-balance dst-mac-vid

!

interface Vlan 120

  no shutdown

!

interface Vlan 132

  no shutdown

!

interface TenGigabitEthernet 2/0/5

no fabric isl enable

no fabric trunk enable

channel-group 1 mode on type standard

no shutdown

!

interface TenGigabitEthernet 2/0/6

no fabric isl enable

no fabric trunk enable

channel-group 2 mode on type standard

no shutdown

!

!

interface TenGigabitEthernet 2/0/9

no fabric isl enable

no fabric trunk enable

channel-group 9 mode active type standard

lacp timeout long

no shutdown

!

interface TenGigabitEthernet 2/0/10

no fabric isl enable

no fabric trunk enable

channel-group 10 mode active type standard

lacp timeout long

no shutdown

!

interface TenGigabitEthernet 2/0/11

fabric isl enable

fabric trunk enable

no shutdown

!

interface TenGigabitEthernet 2/0/12

fabric isl enable

fabric trunk enable

no shutdown

!

interface Port-channel 1

vlag ignore-split

description 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 2

vlag ignore-split

description 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 9

vlag ignore-split

description 9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

interface Port-channel 10

vlag ignore-split

description 10

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

  sh port-c 1

Static Aggregator: Po 1 (vLAG)

Aggregator type: Standard

  Member rbridges:

rbridge-id: 1 (1)
rbridge-id: 2 (1)

Member ports on rbridge-id 2:

   Te 2/0/5

!

sh port-c 2

Static Aggregator: Po 2 (vLAG)

Aggregator type: Standard

  Member rbridges:

    rbridge-id: 1 (1)

    rbridge-id: 2 (1)

Member ports on rbridge-id 2:

   Te 2/0/6

!

sh port-c 9

LACP Aggregator: Po 9 (vLAG)

Aggregator type: Standard

Ignore-split is enabled

  Member rbridges:

    rbridge-id: 1 (1)

    rbridge-id: 2 (1)

  Admin Key: 0009 - Oper Key 0009

  Partner System ID - 0x0001,00-12-f2-cf-18-18

  Partner Oper Key 10010

Member ports on rbridge-id 2:

   Link: Te 2/0/9 (0x218090008) sync: 1

!

sh port-c 10

LACP Aggregator: Po 10 (vLAG)

Aggregator type: Standard

Ignore-split is enabled

  Member rbridges:

    rbridge-id: 1 (1)

    rbridge-id: 2 (1)

  Admin Key: 0010 - Oper Key 0010

  Partner System ID - 0x0001,74-8e-f8-3e-24-00

  Partner Oper Key 10011

Member ports on rbridge-id 2:

   Link: Te 2/0/10 (0x2180A0009) sync: 1

New Contributor
Posts: 2
Registered: ‎03-31-2011

Re: VDX VCS to SX1600 Issue

Sorry one other thing. PC's on the SX are on the 10.10.20.x network as are 2 of the servers 10.10.20.69 and 10.10.20.70 and still the issue is there so it doesn't look to be a VRRP-E routing issue.

Thanks again,

Kevin

Frequent Contributor
Posts: 105
Registered: ‎07-12-2011

Re: VDX VCS to SX1600 Issue

I would open a support case, but am also curious why you aren't using MCT between the SX's and dropping spanning tree out of the mix? You are wasting a lot of links and bandwidth with that design.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.