Ethernet Fabric (VDX, CNA)

Reply
New Member
Posts: 1
Registered: ‎10-02-2013

8470 802.1q trunk over lacp group problem

Hello,

I have an IBM H Blade chassis with a pair of Brocade 8470 Converged 10GE switches in the IO slots.  I am trying to uplink them to a pair of Avaya VSP 7000 switches.  I am using port ExTengigabitEthernet 0/15 and ExTengigabitEthernet 0/16 to up link to two separate but clustered Avaya VSP 7000 switches over a SMLT (split multilink trunk)  The VSP switches are in a cluster pair.  I have port 0/15 and 0/16 on each 8470 configured in a LACP port 802.3ad LAG and I want to use that LAG as a trunk port to carry 802.1q tagged vlan traffic out of the blade center.  I am somewhat convinced the configuration problem is on the Avaya side but though I would post my config here to see if I am missing anything obvious.  No matter what I have tried I can't pass traffic to the north bound Avaya switches over my LAGs.  The LAGs appear to be up/up with counters incrementing on the LAG interfaces on both sides and no errors.  I can successfully ping to and from the vlan 220 interface to the one blade server configured and connected to  InTengigabitEthernet 0/1.  The blade is running esxi 5.1 and I have a Centos VM that I am testing with.  It is configured on a port group that is tagging packets on the 220 vlan.  The chassis also has Cisco 3120 switches in the back that are working fine with a single trunk port uplinked to one VSP 7000.

Here are the relevant parts of the 8470 configs:

prichas2brocade1#sh run

!

hostname prichas2brocade1

!

no protocol spanning-tree

!

cee-map default

priority-group-table 1 weight 40 pfc

priority-group-table 2 weight 60

priority-table 2 2 2 1 2 2 2 2

!

fcoe-map default

fcoe-vlan 1002

!

interface Vlan 1

no shutdown

!

interface Vlan 2

ip address 10.1.2.221/23

no shutdown

!

interface Vlan 160

no shutdown

!

interface Vlan 210

no shutdown

!

interface Vlan 220

ip address 10.1.220.221/23

no shutdown

!

interface Vlan 230

no shutdown

!

interface Vlan 240

no shutdown

!

interface Vlan 250

no shutdown

!

interface InTengigabitEthernet 0/1

track enable

track interface port-channel 23

fcoeport

switchport

switchport mode converged

switchport converged allowed vlan all

no shutdown

!

.

.

.

.

.

.

.

.

!

interface ExTengigabitEthernet 0/15

channel-group 23 mode active type standard

no shutdown

lacp timeout short

cee default

!

interface ExTengigabitEthernet 0/16

channel-group 23 mode active type standard

no shutdown

lacp timeout short

cee default

!

interface ExTengigabitEthernet 0/17

no shutdown

!

interface ExTengigabitEthernet 0/18

no shutdown

!

interface ExTengigabitEthernet 0/19

no shutdown

!

interface ExTengigabitEthernet 0/20

no shutdown

!

interface ExTengigabitEthernet 0/21

no shutdown

!

interface ExTengigabitEthernet 0/22

no shutdown

!

interface Port-channel 23

switchport

switchport mode trunk

switchport trunk allowed vlan add 2

switchport trunk allowed vlan add 160

switchport trunk allowed vlan add 210

switchport trunk allowed vlan add 220

switchport trunk allowed vlan add 230

switchport trunk allowed vlan add 240

switchport trunk allowed vlan add 250

no shutdown

!

protocol lldp

advertise dcbx-fcoe-app-tlv

advertise dcbx-fcoe-logical-link-tlv

!

line console 0

login

line vty 0 31

login

!

end

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook