Ethernet Fabric (VDX, CNA)

New Contributor
Posts: 2
Registered: ‎02-02-2016

6740 - Fabric Virtual Gateway ARP resolving



I have some trouble to get Fabric Virtual Gateway communication with Clavister Firewalls running.


It seems that the FVG only respond to broadcast ARP request and not to the unicast ARP requests from the Clavister.

Already tried „accept unicast arp request“ without success. My workaround is static ARP entries on the Clavister.

After that - Layer 3 communication is possible but no simple „Ping“ between FVG and Clavister.

Error message on Clavister is: „arp_resolution_falied action=remove_entry“

From a Windows (same layer 2 segment) everything seems to fine. I can „Ping“ the VFG and the Clavister.


Does anyone know problems like this? 


Here is a config snip (NOS is on 6.0.2):

router fabric-virtual-gateway

 address-family ipv4



interface Ve 401

 no shutdown

 attach rbridge-id add 42

 ip fabric-virtual-gateway



rbridge-id 42

 interface Ve 402

  vrf forwarding 123

  ip fabric-virtual-gateway


  no shutdown


show ip fabric-virtual-gateway interface ve 401 detail


Interface: Ve 401;  Ifindex: 1207959953

  Admin Status: Enabled

  Description :

  Address family: IPV4    State: Active

  ARP responder Rbridge-id:  42

  Gateway IP:

  Gateway MAC Address: 02e0.5200.01ff

  Load balancing configuration: Enabled

  Load balancing current status: Enabled

  Load balancing threshold priority: unset

  Gratuitous ARP Timer: Disabled

  Hold time: 0 sec  (default: 0 sec)

    Total no. of state changes: 1

    Gratuitous ARP Sent: 1

  Last state change: 0d.21h.11m.43s ago

  Track Priority: 0




New Contributor
Posts: 2
Registered: ‎02-02-2016

Re: 6740 - Fabric Virtual Gateway ARP resolving

Solved, root of the problem was a bug in the native ESX 6.0 MLX driver. :-(

Bug is fixed in v3.2.0.15 Mellanox driver.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.